Problema com adaptador de bluetooth.

Olá,
sou iniciante no linux, uso a versão mate 19.3 e estou tendo problemas com o adaptador de bluetooth que eu possuo.
Bus 001 Device 007: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Ele não consegue parear nenhum dispositivo, baixei o blueman e nada.
O nome é: Dongle Bluetooth CSR 4.0

Comentários

  • Olá meu querido!
    Experimente no terminal o comando sudo service bluetooth restart. Tenho um problema similar, mas no meu caso o bluetooth para depois de já ter sido utilizado.
  • Infelizmente nenhum resultado.
    Não sei se é um problema com o S.O em si ou com a compatibilidade com o sistema.
    Alguém para ajudar?
  • hiyan disse:

    Infelizmente nenhum resultado.
    Não sei se é um problema com o S.O em si ou com a compatibilidade com o sistema.
    Alguém para ajudar?

    Então abra um terminal com o adaptador espetado ao seu PC e comande no terminal:
    lsusb
    Copie toda a saída de lá e cole aqui para o fórum poder tentar lhe auxiliar da melhor forma possível.

    T+
    Perguntas-me qual foi o meu progresso? Comecei a ser amigo de mim mesmo. (Lúcio Aneu Séneca)
    https://paulocorreacreto.blogspot.com/
  • kreto disse:

    hiyan disse:

    Infelizmente nenhum resultado.
    Não sei se é um problema com o S.O em si ou com a compatibilidade com o sistema.
    Alguém para ajudar?

    Então abra um terminal com o adaptador espetado ao seu PC e comande no terminal:
    lsusb
    Copie toda a saída de lá e cole aqui para o fórum poder tentar lhe auxiliar da melhor forma possível.

    T+
    tenho o mesmo problema com o adaptador bluetooth
    [email protected]:~$ lsusb
    Bus 002 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
    Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  • Desculpe a demora é que aqui para mim o fórum estava om problemas.
    Mas, vemos que seu adaptador bluetooth está presente menos mal. Continue no terminal e comande
    hciconfig
    Dependendo da saída
    hciconfig -a hci0

    Onde o 0 (zero) em hci0 pode mudar no seu Pc e daí terá que olhar a saída do primeiro comando

    T+
    Perguntas-me qual foi o meu progresso? Comecei a ser amigo de mim mesmo. (Lúcio Aneu Séneca)
    https://paulocorreacreto.blogspot.com/
  • editado 4 de July
    kreto disse:

    Desculpe a demora é que aqui para mim o fórum estava om problemas.
    Mas, vemos que seu adaptador bluetooth está presente menos mal. Continue no terminal e comande
    hciconfig
    Dependendo da saída
    hciconfig -a hci0

    Onde o 0 (zero) em hci0 pode mudar no seu Pc e daí terá que olhar a saída do primeiro comando

    T+


    apareceu isso

    [email protected]:~$ hciconfig
    hci0: Type: Primary Bus: USB
    BD Address: 00:1A:7D:DA:71:06 ACL MTU: 384:8 SCO MTU: 64:8
    UP RUNNING PSCAN ISCAN
    RX bytes:633 acl:0 sco:0 events:39 errors:0
    TX bytes:900 acl:0 sco:0 commands:33 errors:0

    [email protected]:~$ hciconfig -a hci0
    hci0: Type: Primary Bus: USB
    BD Address: 00:1A:7D:DA:71:06 ACL MTU: 384:8 SCO MTU: 64:8
    UP RUNNING PSCAN ISCAN INQUIRY
    RX bytes:2152 acl:1 sco:0 events:176 errors:0
    TX bytes:1394 acl:0 sco:0 commands:86 errors:0
    Features: 0xff 0xff 0x8f 0xfe 0x9b 0xf9 0x00 0x80
    Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
    Link policy: RSWITCH HOLD SNIFF PARK
    Link mode: SLAVE ACCEPT
    Name: 'lucas-AHV'
    Class: 0x1c0104
    Service Classes: Rendering, Capturing, Object Transfer
    Device Class: Computer, Desktop workstation
    HCI Version: 2.0 (0x3) Revision: 0x7a6
    LMP Version: 2.0 (0x3) Subversion: 0x7a6
    Manufacturer: Cambridge Silicon Radio (10)
    Post edited by lucascb32 on
  • kretokreto Creto
    editado 5 de July
    Ok, agradeço pela sua atenção ao tópico B)

    Então vamos continuar a nossa busca comande:

    lspci -nnk | grep -iA3 net; lsusb; dmesg | egrep -i 'blue|firm'

    Se no final você obter algo como:

    [email protected]:~$ lspci -nnk | grep -iA3 net; lsusb; dmesg | egrep -i 'blue|firm' 03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c) Subsystem: Elitegroup Computer Systems RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [1019:017f] Kernel driver in use: r8169 Kernel modules: r8169 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 001 Device 004: ID 1a2c:2d23 China Resource Semico Co., Ltd Bus 001 Device 003: ID 03f0:c211 HP, Inc Deskjet 2540 series Bus 001 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub [ 0.123501] Spectre V2 : Enabling Restricted Speculation for firmware calls [ 11.593085] Bluetooth: Core ver 2.22 [ 11.593116] Bluetooth: HCI device and connection manager initialized [ 11.593122] Bluetooth: HCI socket layer initialized [ 11.593125] Bluetooth: L2CAP socket layer initialized [ 11.593132] Bluetooth: SCO socket layer initialized [ 11.754804] Bluetooth: HCI UART driver ver 2.3 [ 11.754808] Bluetooth: HCI UART protocol H4 registered [ 11.754809] Bluetooth: HCI UART protocol BCSP registered [ 11.754831] Bluetooth: HCI UART protocol LL registered [ 11.754833] Bluetooth: HCI UART protocol ATH3K registered [ 11.754849] Bluetooth: HCI UART protocol Three-wire (H5) registered [ 11.754888] Bluetooth: HCI UART protocol Intel registered [ 11.754928] Bluetooth: HCI UART protocol Broadcom registered [ 11.754945] Bluetooth: HCI UART protocol QCA registered [ 11.754947] Bluetooth: HCI UART protocol AG6XX registered [ 11.754962] Bluetooth: HCI UART protocol Marvell registered [ 31.824796] Bluetooth: BNEP (Ethernet Emulation) ver 1.3 [ 31.824799] Bluetooth: BNEP filters: protocol multicast [ 31.824806] Bluetooth: BNEP socket layer initialized [email protected]:~$

    Veja também se o adaptador está carregando apenas com:

    dmesg | grep -i blue

    E com isso vou indicar também algumas leituras para que você tenha mais informações sobre o assunto do seu adaptador:
    https://qastack.com.br/ubuntu/1078847/how-to-set-up-bluetooth-in-ubuntu-18-04
    https://qastack.com.br/ubuntu/490346/bluetooth-not-working-in-ubuntu-14-04-lts

    Leituras de problemas bem parecidos, que mostram algumas possíveis soluções, como a verificação de alguns componentes/apps que podem estar faltando ai.

    Ou seja verifique mesmo se os bluez e bluez-utils estão instalados:
    apt-cache policy bluez bluez-utils

    Se não estiverem instale-os:
    sudo apt update ; sudo apt install bluez bluez-utils

    Depois:
    sudo /etc/init.d/bluetooth restart

    Vamos na busca...

    T+

    Post edited by kreto on
    Perguntas-me qual foi o meu progresso? Comecei a ser amigo de mim mesmo. (Lúcio Aneu Séneca)
    https://paulocorreacreto.blogspot.com/
Entre ou Registre-se para fazer um comentário.