Aplicação PHP

Salve amigos, depois de muito tempo resolvi voltar para o mundo Linux, mais precisamente o MINT, antigamente usava o velho Ubuntu de guerra, mas depois do Unity fiquei abusado dele.

Mas vamos ao meu problema:

Instalei o Mint para rodar uma aplicação em PHP, - Apache - Sql e PHPMYADMIN rodando de boa. configurei a aplicação e voilá rodando de boa no navegador. Antes com o Windows e o Xamp não rodou nem a pau...

digito: localhost/geradoc e carrega o php, coloco a senha e aplicação rodando redondamente.

Acontece que preciso rodar em outras máquinas, vou no navegador e digito:

endereço-ip do Mint/geradoc - chega a carregar, mas sem o layout ou as imagens; coloco o o usuário e senha e dá página não encontrada (ele muda automaticamente para localhost/geradoc/login) e com isso não carrega.

É uma besteirinha de resolução de nomes mas como estou muito enferrujado....

Comentários

  • editado February 2020
    Pode ser a configuração do apache errada no http.conf
    da uma olhada nas configuraçõe, ve se o parametro Listen está "escutando" a porta 80 e não localhost:80 ou 127.0.0.1:80



    ou pode ser um problema da configuração do geradoc, o geradoc é um sistema desenvolvido por você, ou é esse aqui? https://github.com/tarsodecastro/geradoc
    caso seja esse, você instalou o php 5.3, ou instalou o 7?

    se na configuração do programa você colocou localhost, você pode trocar para $_SERVER ['SERVER_ADDR']

    $config['base_url'] = "http://${_SERVER ['SERVER_ADDR']}/geradoc"
Entre ou Registre-se para fazer um comentário.