boot demorando.

Oi, pessoal. Espero que tds bem!

Uso Linux Mint 20.1 (Cinnamon) em dual boot com Win10, ambos em um SSD. Uso tb um HDD de 1TB, que formatei semana passada para apagar instalações antigas do Linux e do Win10 (as que eu usava antes de instalar o SSD). Depois de formatar o HDD, percebi que o Mint está com boot bem mais lento que o usual. Já usei um ponto de restauração no Timeshift para antes de algumas atualizações importantes (kernel) recentes, e continuo com o problema. Será que perdi alguma configuração quando apaguei meu HDD, e isso está interferindo no boot? Alguém poderia me ajudar a resolver? Abaixo algumas informações úteis:

inxi -Fxxxrz
System:
Kernel: 5.4.0-90-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
Desktop: Cinnamon 4.8.6 info: plank wm: muffin 4.8.1 dm: LightDM 1.30.0
Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal
Machine:
Type: Laptop System: Acer product: Aspire F5-573G v: V1.25
serial: <filter>
Mobo: Acer model: Captain_SK v: V1.25 serial: <filter> UEFI: Insyde
v: 1.25 date: 03/03/2017
Battery:
ID-1: BAT1 charge: 22.3 Wh condition: 31.4/32.1 Wh (98%) volts: 15.9/14.6
model: PANASONIC AS16A5K type: Li-ion serial: <filter> status: Charging
CPU:
Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP
arch: Amber Lake rev: 9 L2 cache: 3072 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 21599
Speed: 500 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 506 2: 511
3: 550 4: 515
Graphics:
Device-1: Intel HD Graphics 620 vendor: Acer Incorporated ALI driver: i915
v: kernel bus ID: 00:02.0 chip ID: 8086:5916
Device-2: NVIDIA GM107 [GeForce 940MX] vendor: Acer Incorporated ALI
driver: nvidia v: 390.144 bus ID: 01:00.0 chip ID: 10de:179c
Display: x11 server: X.Org 1.20.11 driver: modesetting,nvidia
unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce 940MX/PCIe/SSE2 v: 4.6.0 NVIDIA 390.144
direct render: Yes
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71
Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX]
vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
bus ID: 01:00.1 chip ID: 10de:0fbc
Sound Server: ALSA v: k5.4.0-90-generic
Network:
Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
vendor: Lite-On driver: ath9k v: kernel port: 4000 bus ID: 03:00.0
chip ID: 168c:0036
IF: wlp3s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000
bus ID: 04:00.1 chip ID: 10ec:8168
IF: enp4s0f1 state: up speed: 100 Mbps duplex: full mac: <filter>
Device-3: Lite-On Qualcomm Atheros Bluetooth type: USB driver: btusb
bus ID: 1-5:5 chip ID: 04ca:3014
Drives:
Local Storage: total: 1.38 TiB used: 110.49 GiB (7.8%)
ID-1: /dev/nvme0n1 model: XrayDisk 512GB size: 476.94 GiB speed: 31.6 Gb/s
lanes: 4 serial: <filter> rev: T0918A0L scheme: GPT
ID-2: /dev/sda vendor: Western Digital model: WD10JPVX-22JC3T0
size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter>
rev: 1A01 scheme: MBR
Partition:
ID-1: / size: 131.92 GiB used: 110.45 GiB (83.7%) fs: ext4
dev: /dev/nvme0n1p6
ID-2: swap-1 size: 14.90 GiB used: 0 KiB (0.0%) fs: swap
dev: /dev/nvme0n1p5
Sensors:
System Temperatures: cpu: 59.0 C mobo: N/A gpu: nvidia temp: 56 C
Fan Speeds (RPM): N/A
Repos:
No active apt repos in: /etc/apt/sources.list
Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
1: deb http://mint-packages.c3sl.ufpr.br ulyssa main upstream import backport
2: deb http://ubuntu-archive.locaweb.com.br/ubuntu focal main restricted universe multiverse
3: deb http://ubuntu-archive.locaweb.com.br/ubuntu focal-updates main restricted universe multiverse
4: deb http://ubuntu-archive.locaweb.com.br/ubuntu focal-backports main restricted universe multiverse
5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
6: deb http://archive.canonical.com/ubuntu/ focal partner
Active apt repos in: /etc/apt/sources.list.d/spotify.list
1: deb http://repository.spotify.com stable non-free
Active apt repos in: /etc/apt/sources.list.d/yannubuntu-boot-repair-focal.list
1: deb http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu focal main
Info:
Processes: 224 Uptime: 4m Memory: 15.51 GiB used: 1.43 GiB (9.2%)
Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash
v: 5.0.17 running in: gnome-terminal inxi: 3.0.38
systemd-analyze
Startup finished in 3.633s (firmware) + 4.236s (loader) + 3.083s (kernel) + 1min 31.046s (userspace) = 1min 41.999s 
graphical.target reached after 1min 31.031s in userspace
systemd-analyze blame
772ms dev-nvme0n1p6.device                                                     
520ms systemd-rfkill.service
463ms systemd-logind.service
421ms plymouth-quit-wait.service
407ms lightdm.service
407ms udisks2.service
403ms networkd-dispatcher.service
336ms dev-disk-by\x2duuid-6934eab0\x2dfe82\x2d4f66\x2d93d0\x2d2ae74fa027da.swap
294ms accounts-daemon.service
251ms ubuntu-system-adjustments.service
227ms systemd-resolved.service
198ms systemd-timesyncd.service
185ms networking.service
177ms e2scrub_reap.service
168ms avahi-daemon.service
160ms gpu-manager.service
138ms bluetooth.service
137ms NetworkManager.service
136ms systemd-udev-trigger.service
125ms keyboard-setup.service
123ms systemd-journald.service
118ms ModemManager.service
117ms upower.service
114ms [email protected]
112ms polkit.service
109ms systemd-udevd.service
105ms boot-efi.mount
99ms systemd-journal-flush.service
97ms thermald.service
95ms lvm2-monitor.service
90ms alsa-restore.service
90ms kerneloops.service
89ms secureboot-db.service
88ms hddtemp.service
84ms apparmor.service
84ms wpa_supplicant.service
77ms grub-common.service
58ms systemd-modules-load.service
52ms colord.service
46ms lm-sensors.service
45ms [email protected]\x2duuid-24CC\x2d8E78.service
43ms rsyslog.service
41ms dns-clean.service
37ms systemd-tmpfiles-setup.service
35ms grub-initrd-fallback.service
30ms systemd-sysctl.service
29ms pppd-dns.service
28ms systemd-sysusers.service
23ms systemd-tmpfiles-setup-dev.service
22ms dev-hugepages.mount
22ms dev-mqueue.mount
21ms sys-kernel-debug.mount
20ms sys-kernel-tracing.mount
18ms systemd-remount-fs.service
18ms console-setup.service
18ms blk-availability.service
16ms plymouth-start.service
16ms kmod-static-nodes.service
15ms [email protected]
14ms systemd-random-seed.service
13ms systemd-update-utmp.service
12ms plymouth-read-write.service
11ms systemd-update-utmp-runlevel.service
10ms [email protected]:intel_backlight.service
8ms systemd-user-sessions.service
7ms setvtrgb.service
5ms finalrd.service
5ms ufw.service
4ms ifupdown-pre.service
4ms rtkit-daemon.service
4ms sys-kernel-config.mount
3ms sys-fs-fuse-connections.mount
2ms openvpn.service
systemd-analyze time
Startup finished in 3.633s (firmware) + 4.236s (loader) + 3.083s (kernel) + 1min 31.046s (userspace) = 1min 41.999s 
graphical.target reached after 1min 31.031s in userspace

Comentários

  • Tou pesquisando alguns tópicos semelhantes, executei os seguintes comandos:

    blkid
    /dev/nvme0n1p1: UUID="24CC-8E78" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="66c7e533-cbb3-4775-817d-cbc5496161fa"
    /dev/nvme0n1p3: UUID="3468D95968D91A86" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="481aada8-4d83-4916-908b-370c148852b8"
    /dev/nvme0n1p4: UUID="6E3C946E3C9432D7" TYPE="ntfs" PARTUUID="5ac72f99-f5d9-4b63-adcd-4697f4104ae1"
    /dev/nvme0n1p5: UUID="6934eab0-fe82-4f66-93d0-2ae74fa027da" TYPE="swap" PARTUUID="20c583fc-16e4-4aea-9748-5caf7554046b"
    /dev/nvme0n1p6: UUID="27eebd06-c4e5-4cd1-8f3d-636ffe58ab03" TYPE="ext4" PARTUUID="b6c89964-7fe7-4334-bb99-e2f25ad4daa9"
    /dev/sda1: UUID="E2521FAE521F8707" TYPE="ntfs" PARTUUID="d24fae74-01"
    sudo cat /etc/fstab
    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    # / was on /dev/nvme0n1p6 during installation
    UUID=27eebd06-c4e5-4cd1-8f3d-636ffe58ab03 / ext4 errors=remount-ro 0 1
    # /boot/efi was on /dev/nvme0n1p1 during installation
    #UUID=24CC-8E78 /boot/efi vfat umask=0077 0 1
    # swap was on /dev/nvme0n1p5 during installation
    UUID=6934eab0-fe82-4f66-93d0-2ae74fa027da none swap sw 0 0
    # swap was on /dev/sda4 during installation
    UUID=69836155-4a55-4fff-9c1d-03b1c36f50e2 none swap sw 0 0
    UUID=24CC-8E78 /boot/efi vfat defaults 0
    Reparem que no segundo código tem uma partição swap e uma EFI a mais, respectivas ao Mint que eu usava no HDD, imagino. Será isso que está causando o problema? Alguém sabe como resolver?
  • Resolvido! Quando eu reinstalei o atualizei o grub depois de ter formatado o HDD (para arrumar as entradas do grub), o arquivo fstab não foi atualizado junto, então tinham duas entradas inválidas nele e isso estava deixando o boot lento. Para arrumar:

    sudo gedit /etc/fstab
    Apaguei as entradas inválidas:

    # swap was on /dev/sda4 during installation
    UUID=69836155-4a55-4fff-9c1d-03b1c36f50e2 none swap sw 0 0
    UUID=24CC-8E78 /boot/efi vfat defaults 0

    Salvei e reiniciei. Prontinho, boot normal.

  • Resolvido! Quando eu reinstalei o atualizei o grub depois de ter formatado o HDD (para arrumar as entradas do grub), o arquivo fstab não foi atualizado junto, então tinham duas entradas inválidas nele e isso estava deixando o boot lento. Para arrumar:

    sudo gedit /etc/fstab
    Apaguei as entradas inválidas:

    # swap was on /dev/sda4 during installation
    UUID=69836155-4a55-4fff-9c1d-03b1c36f50e2 none swap sw 0 0
    UUID=24CC-8E78 /boot/efi vfat defaults 0

    Salvei e reiniciei. Prontinho, boot normal.

    Parabéns pela solução e retorno com a dica de como resolveu.
Entre ou Registre-se para fazer um comentário.