Erro de dependência do pacote libc6 ao instalar kernel 5.12.8 estragou a instalação de pacotes

Eu tentei instalar o kernel 5.12.8 no linux mint Ulyssa 20.1 de maneira atrapalhada. Eu baixei os pacotes amd e rodei dpkg -i *.deb. Então deu erro da versão do pacote libc6. Eu tentei instalar manualmente. Na instalação manual disse que ia remover o pacote fakeroot e apresentou erro de configuração no arquivo linux-header do kernel. Depois disso os pacotes ficaram quebrados e não consegui corrigir com apt-get install -f e nem com o synaptic. Eu tentei rodar o apt-get install -f mesmo com aviso de estar potencialmente estragando gravemente o sistema. Esse comando não foi bem-sucedido. Ele interrompe com a mensagem final do log a seguir:

Log started: 2021-05-31 16:41:19
dpkg: warning: 'ldconfig' not found in PATH or not executable
dpkg: error: 1 expected program not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
Log ended: 2021-05-31 16:41:20

O log do dpkg mostra que vários pacotes ligados com o pacote libc6 dependem dele numa versão específica. Eu tenho os logs do apt e do dpkg.

Por exempo:

A remover libcrypt1:i386 (1:4.4.10-10ubuntu4) ...
dpkg: libc6:i386: problemas com dependências, mas mesmo assim a remover conforme você pediu:
zlib1g:i386 depende de libc6 (>= 2.4).
xaw3dg:i386 depende de libc6 (>= 2.4).
wine32:i386 depende de libc6 (>= 2.28).
odbcinst1debian2:i386 depende de libc6 (>= 2.4).
ocl-icd-libopencl1:i386 depende de libc6 (>= 2.4).
mesa-vulkan-drivers:i386 depende de libc6 (>= 2.29).
libzvbi0:i386 depende de libc6 (>= 2.29).
libzstd1:i386 depende de libc6 (>= 2.4).
libxxf86vm1:i386 depende de libc6 (>= 2.4).
libxvidcore4:i386 depende de libc6 (>= 2.29).
libxv1:i386 depende de libc6 (>= 2.4).
libxtst6:i386 depende de libc6 (>= 2.4).

É a primeira vez que eu peço ajuda num Fórum de Linux. Estou usando Linux Mint desde 2012. Não consegui anexar o arquivo de log em formato txt.

Comentários

  • Copia tudo esse comando e cola no terminal.

    sudo rm -Rf /var/lib/apt/lists/* ; sudo rm -Rf /var/lib/apt/lists/* ; sudo mkdir -p /var/lib/apt/lists/partial/* sudo rm -Rf /var/lib/apt/lists/partial/* ; sudo rm -r /var/lib/apt/lists/partial/* ; sudo rm -r /var/lib/apt/lists/* -vf ; sudo apt-get -f install ; sudo apt-get clean ; sudo apt update ; sudo dpkg --configure -a ; sudo apt dist-upgrade ; sudo apt-get clean ; sudo apt-get autoremove ; sudo apt-get autoclean

    Veja se ele resolve os problemas.
  • editado June 3
    O comando sudo apt-get install -f diz que vai remover 378 pacotes e 1 não atualizado. 2 não instalados completamente ou removidos.
    Ele para nesse erro:
    perl: warning: Setting locale failed.
    perl: warning: Please check that out locale settings:
    LANGUAGE = "pt_BR:pt:en",
    LC_ALL = (unset),
    LANG = "C.UTF-8"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    Can't exec "locale": No such file or directory at /usr/share/perl5/Debconf/Enconding.pm line 16.
    Use of unitialized value $Debconf::Enconding::charmap in scalar chomp at /usr/share/perl5/Debconf/Enconding.pm line 17.
    dpkg: warning: 'ldconfig' not found in PATH or not executable
    dpkg: error: 1 expected program not found in PATH or not executable
    Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
    E: Sub-process /usr/bin/dpkg returned an error code (2)
  • editado June 3
    Eu digitei o comando locale no terminal e disse que precisava instalar o pacote libc-bin. Mas o sistema de instalação de pacotes está quebrado.
  • editado June 3
    Encontrei um tópico sobre locales e não conseguir instalar mais nada. Comentaram que quando uma instalação falha é um erro grave instalar um pacote manualmente em cima. Não conseguiram resolver. Disseram para reinstalar o mint. https://forums.linuxmint.com/viewtopic.php?t=276077
Entre ou Registre-se para fazer um comentário.