[Resolvido] microfone interno não funciona. (Acer Aspire-F5)

2»

Comentários

  • [email protected]:~$ arecord -f dat -r 60000 -D hw:0,0 -d 5 test.wav
    Recording WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 60000 Hz, Stereo
    Warning: rate is not accurate (requested = 60000Hz, got = 48000Hz)
    please, try the plug plugin
    [email protected]:~$ grep "default-sample-rate" /etc/pulse/daemon.conf
    ; default-sample-rate = 44100
    reparem que o meu pc já está com a taxa de amostragem padrão (no meu caso em 44100) abaixo do máximo suportável na maquina (48000Hz) e ainda assim sigo com o ruído bizarro nas gravações do mic. De qualquer forma não consigo mudar esse padrão pro maximo nem pra nenhum outra potencia pq sou um usuario iniciante. Tentei a outra possivel causa para o ruído chiado mas por esse caminho nao consigo avançar nada, nao consigo realizar os comandos ou nao entendo a linguagem/procedimentos que estao ali explicados. seria isso que nao consigo fazer:

    Another Possible Cause
    Another possible cause is that your mic has two channels but only one channel can provide a valid sound signal. Some information can be found here. The solution is to remap the stereo input to a mono input:
    1. Find your source name from the following command; mine is alsa_input.pci-0000_00_1f.3.analog-stereo
    pacmd list-sources | grep 'name:.*input'
    2. Edit /etc/pulse/default.pa and add the following lines, where INPUT_NAME is name of the input source from above step:
    load-module module-remap-source source_name=record_mono master=INPUT_NAME master_channel_map=front-left channel_map=mono
    set-default-source record_mono
    3. Restart PulseAudio:
    $ pulseaudio -k
    $ pulseaudio --start
    Now arecord hopefully works. You may still need to change the RecordStream from setting to Remapped Built-in Audio Analog Stereo of a specific application in the Recording tab of pavucontrol.

    Como podem ver, estou bem ferrado e agradeço muito qualquer ajuda. Valeu mesmo pessoal!

    Fala, Fabrício. Desconfio que seu problema seja bem simples e não envolva questões complexas no terminal. Lhe recomendo desativar o boost do microfone no alsamixer, digitando 'alsamixer' no terminal, pressionando F4 pra exibir os dispositivos de captura e em seguindo diminuindo o volume do bost do microfone, semelhante ao meu:


  • [email protected]:~$ arecord -f dat -r 60000 -D hw:0,0 -d 5 test.wav
    Recording WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 60000 Hz, Stereo
    Warning: rate is not accurate (requested = 60000Hz, got = 48000Hz)
    please, try the plug plugin
    [email protected]:~$ grep "default-sample-rate" /etc/pulse/daemon.conf
    ; default-sample-rate = 44100
    reparem que o meu pc já está com a taxa de amostragem padrão (no meu caso em 44100) abaixo do máximo suportável na maquina (48000Hz) e ainda assim sigo com o ruído bizarro nas gravações do mic. De qualquer forma não consigo mudar esse padrão pro maximo nem pra nenhum outra potencia pq sou um usuario iniciante. Tentei a outra possivel causa para o ruído chiado mas por esse caminho nao consigo avançar nada, nao consigo realizar os comandos ou nao entendo a linguagem/procedimentos que estao ali explicados. seria isso que nao consigo fazer:

    Another Possible Cause
    Another possible cause is that your mic has two channels but only one channel can provide a valid sound signal. Some information can be found here. The solution is to remap the stereo input to a mono input:
    1. Find your source name from the following command; mine is alsa_input.pci-0000_00_1f.3.analog-stereo
    pacmd list-sources | grep 'name:.*input'
    2. Edit /etc/pulse/default.pa and add the following lines, where INPUT_NAME is name of the input source from above step:
    load-module module-remap-source source_name=record_mono master=INPUT_NAME master_channel_map=front-left channel_map=mono
    set-default-source record_mono
    3. Restart PulseAudio:
    $ pulseaudio -k
    $ pulseaudio --start
    Now arecord hopefully works. You may still need to change the RecordStream from setting to Remapped Built-in Audio Analog Stereo of a specific application in the Recording tab of pavucontrol.

    Como podem ver, estou bem ferrado e agradeço muito qualquer ajuda. Valeu mesmo pessoal!

    Outra questão é o nível dos dispositivos de entrada no pulse audio, tente deixar algo semelhante a isso:




  • [email protected]:~$ arecord -f dat -r 60000 -D hw:0,0 -d 5 test.wav
    Recording WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 60000 Hz, Stereo
    Warning: rate is not accurate (requested = 60000Hz, got = 48000Hz)
    please, try the plug plugin
    [email protected]:~$ grep "default-sample-rate" /etc/pulse/daemon.conf
    ; default-sample-rate = 44100
    reparem que o meu pc já está com a taxa de amostragem padrão (no meu caso em 44100) abaixo do máximo suportável na maquina (48000Hz) e ainda assim sigo com o ruído bizarro nas gravações do mic. De qualquer forma não consigo mudar esse padrão pro maximo nem pra nenhum outra potencia pq sou um usuario iniciante. Tentei a outra possivel causa para o ruído chiado mas por esse caminho nao consigo avançar nada, nao consigo realizar os comandos ou nao entendo a linguagem/procedimentos que estao ali explicados. seria isso que nao consigo fazer:

    Another Possible Cause
    Another possible cause is that your mic has two channels but only one channel can provide a valid sound signal. Some information can be found here. The solution is to remap the stereo input to a mono input:
    1. Find your source name from the following command; mine is alsa_input.pci-0000_00_1f.3.analog-stereo
    pacmd list-sources | grep 'name:.*input'
    2. Edit /etc/pulse/default.pa and add the following lines, where INPUT_NAME is name of the input source from above step:
    load-module module-remap-source source_name=record_mono master=INPUT_NAME master_channel_map=front-left channel_map=mono
    set-default-source record_mono
    3. Restart PulseAudio:
    $ pulseaudio -k
    $ pulseaudio --start
    Now arecord hopefully works. You may still need to change the RecordStream from setting to Remapped Built-in Audio Analog Stereo of a specific application in the Recording tab of pavucontrol.

    Como podem ver, estou bem ferrado e agradeço muito qualquer ajuda. Valeu mesmo pessoal!

    Fala, Fabrício. Desconfio que seu problema seja bem simples e não envolva questões complexas no terminal. Lhe recomendo desativar o boost do microfone no alsamixer, digitando 'alsamixer' no terminal, pressionando F4 pra exibir os dispositivos de captura e em seguindo diminuindo o volume do bost do microfone, semelhante ao meu:


    valeu pela ajuda camarada! Mas nao consegui resolver...no meu terminal, quando vou pro alsamixer, o F4 só corta ou ativa o som do pc. Ainda no alsamixer, não mostra os microfones, só a barra MASTER e quando aperto F5 ele mostra uma barra CAPTURE, e essa mesa barra muda o nome para R e L quando aperto o space....nada além disso. Já tentei reduzir essa barra pro area verde, mas nao funcionou. E não sei chegar na segunda imagem q vc mandou, pra controlar o nivel dos dispositivos de audio. agradeço qualquer ajuda. abraço
Entre ou Registre-se para fazer um comentário.