[Resolvido] microfone interno não funciona. (Acer Aspire-F5)

Suadações, pessoal.

Recentemente comecei a usar o Linux Mint Xfce 20.04. Acabei constatando hoje que meu microfone interno não está funcionando por aqui. Uso dual boot, e no Windows está tudo ok. Será que alguém poderia ajudar a resolver?

Sistema:
System:
Kernel: 5.4.0-60-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
Desktop: Xfce 4.14.2 Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal
Machine:
Type: Laptop System: Acer product: Aspire F5-573G v: V1.25 serial: <filter>
Mobo: Acer model: Captain_SK v: V1.25 serial: <filter> UEFI: Insyde v: 1.25
date: 03/03/2017
Battery:
ID-1: BAT1 charge: 14.6 Wh condition: 14.6/41.4 Wh (35%)
model: PANASONIC AS16A5K status: Full
CPU:
Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP
arch: Amber Lake rev: 9 L2 cache: 3072 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 21599
Speed: 600 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 600 2: 595 3: 600
4: 589
Graphics:
Device-1: Intel HD Graphics 620 vendor: Acer Incorporated ALI driver: i915
v: kernel bus ID: 00:02.0
Device-2: NVIDIA GM107 [GeForce 940MX] vendor: Acer Incorporated ALI
driver: nvidia v: 460.32.03 bus ID: 01:00.0
Display: server: X.Org 1.20.9 driver: modesetting,nvidia
unloaded: fbdev,nouveau,vesa resolution: 1366x768~60Hz
OpenGL: renderer: GeForce 940MX/PCIe/SSE2 v: 4.6.0 NVIDIA 460.32.03
direct render: Yes
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel bus ID: 00:1f.3
Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX]
driver: snd_hda_intel v: kernel bus ID: 01:00.1
Sound Server: ALSA v: k5.4.0-60-generic
Dispositivos de som:
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC255 Analog [ALC255 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
Subdevices: 1/1
Subdevice #0: subdevice #0
Desde já, agradeço pela atenção!
«1

Comentários

  • Suadações, pessoal.

    Recentemente comecei a usar o Linux Mint Xfce 20.04. Acabei constatando hoje que meu microfone interno não está funcionando por aqui. Uso dual boot, e no Windows está tudo ok. Será que alguém poderia ajudar a resolver?

    Sistema:
    System:
    Kernel: 5.4.0-60-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
    Desktop: Xfce 4.14.2 Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal
    Machine:
    Type: Laptop System: Acer product: Aspire F5-573G v: V1.25 serial: <filter>
    Mobo: Acer model: Captain_SK v: V1.25 serial: <filter> UEFI: Insyde v: 1.25
    date: 03/03/2017
    Battery:
    ID-1: BAT1 charge: 14.6 Wh condition: 14.6/41.4 Wh (35%)
    model: PANASONIC AS16A5K status: Full
    CPU:
    Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP
    arch: Amber Lake rev: 9 L2 cache: 3072 KiB
    flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
    bogomips: 21599
    Speed: 600 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 600 2: 595 3: 600
    4: 589
    Graphics:
    Device-1: Intel HD Graphics 620 vendor: Acer Incorporated ALI driver: i915
    v: kernel bus ID: 00:02.0
    Device-2: NVIDIA GM107 [GeForce 940MX] vendor: Acer Incorporated ALI
    driver: nvidia v: 460.32.03 bus ID: 01:00.0
    Display: server: X.Org 1.20.9 driver: modesetting,nvidia
    unloaded: fbdev,nouveau,vesa resolution: 1366x768~60Hz
    OpenGL: renderer: GeForce 940MX/PCIe/SSE2 v: 4.6.0 NVIDIA 460.32.03
    direct render: Yes
    Audio:
    Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel bus ID: 00:1f.3
    Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX]
    driver: snd_hda_intel v: kernel bus ID: 01:00.1
    Sound Server: ALSA v: k5.4.0-60-generic
    Dispositivos de som:
    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: ALC255 Analog [ALC255 Analog]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
    Subdevices: 1/1
    Subdevice #0: subdevice #0

    Desde já, agradeço pela atenção!
    O volume de captação do microfone, como está? Verifique na aba "Entrada" das configurações de som.

  • Obrigado pela resposta, @malvescardoso

    Estou certo de que o problema não era esse. Segui alguns comandos no troubleshooting do PulseAudio, digamos que obtive um bom progresso em relação ao início.

    O primeiro passo foi reconhecer meu microfone interno no PulseAudio:
    Usei
    arecord -l
    para identificar a placa e o dispositivo;
    Em seguida editei o arquivo /etc/pulse/default.pa adicionando a linha
    load-module module-alsa-source device=hw:0,0
    acima de
    .ifexists module-udev-detect.so
    Quem tiver com o mesmo problema deve substituir hw:0,0 pelos números obtidos pras suas respectivas placas e dispositivos.

    Assim, o microfone interno passou a ser reconhecido no PulseAudio, mas ainda não captava som.

    Em seguida, foi necessário mudar a frequência da taxa de amostragem padrão do PulseAudio. Pra identificar a taxa máxima suportada pela placa, executar:
    arecord -f dat -r 60000 -D hw:0,0 -d 5 test.wav
    A taxa de amostragem padrão do PulseAudio é obtida executando:
    grep "default-sample-rate" /etc/pulse/daemon.conf
    Enfim, para mudar a taxa de amostragem, executei o comando adaptando-o com as taxas obtidas pro meu sistema
    sudo sed 's/; default-sample-rate = 48000/default-sample-rate = 44100/g' -i /etc/pulse/daemon.conf
    Feito isso, reiniciei o PulseAudio
    pulseaudio -k
    pulseaudio --start
    e testei a captação, o que funcionou, mas com estática.

    Pra melhorar a estática, alterei algumas configurações do PulseAudio em
    /etc/pulse/daemon.conf
    utilizando
    resample-method = src-sinc-best-quality
    o que melhorou um bocado, mas ainda não está perfeito. Seguirei pesquisando, novidades posto por aqui.

  • Enfim, mutando o boost do microfone interno no alsamixer consegui um áudio agradável.
  • Enfim, mutando o boost do microfone interno no alsamixer consegui um áudio agradável.

    Ótimo! Obrigado por compartilhar.

    Por favor, adicione o rótulo "[Resolvido]" ao título, como indicamos em nossas recomendações. Obrigado.

    Fique com Deus.


  • editado January 15

    Obrigado pela resposta, @malvescardoso

    Estou certo de que o problema não era esse.

    Acredite: Já tivemos alguns casos em que só faltou o ajuste do volume. Por isso, indiquei.

  • Obrigado pela resposta, @malvescardoso

    Estou certo de que o problema não era esse.

    Acredite: Já tivemos alguns casos em que só faltou o ajuste do volume. Por isso, indiquei.

    Eu imagino, deve acontecer de tudo! Inclusive, tou precisando de ajuda pra editar o título da discussão pra [Resolvido]. :3
  • tou precisando de ajuda pra editar o título da discussão pra [Resolvido]. :3

    Feito.

  • Olá pessoal, tenho o linux mint num lenovo ideapad 320 e estou com problema de chiado insuportavel nos audios que gravo pelo meu mic. Nao consigo nem mesmo manter o mic aberto em uma reuniao de trabalho no meet ou skipe. Tentei seguir os caminhos indicados acima e também os do PulseAudio/Troubleshooting para "static noises" no mic mas nao resolveu. Agredeço muito a ajuda de vcs!!!
  • [email protected]:~$ arecord -f dat -r 60000 -D hw:0,0 -d 5 test.wav
    Recording WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 60000 Hz, Stereo
    Warning: rate is not accurate (requested = 60000Hz, got = 48000Hz)
    please, try the plug plugin
    [email protected]:~$ grep "default-sample-rate" /etc/pulse/daemon.conf
    ; default-sample-rate = 44100
    reparem que o meu pc já está com a taxa de amostragem padrão (no meu caso em 44100) abaixo do máximo suportável na maquina (48000Hz) e ainda assim sigo com o ruído bizarro nas gravações do mic. De qualquer forma não consigo mudar esse padrão pro maximo nem pra nenhum outra potencia pq sou um usuario iniciante. Tentei a outra possivel causa para o ruído chiado mas por esse caminho nao consigo avançar nada, nao consigo realizar os comandos ou nao entendo a linguagem/procedimentos que estao ali explicados. seria isso que nao consigo fazer:

    Another Possible Cause
    Another possible cause is that your mic has two channels but only one channel can provide a valid sound signal. Some information can be found here. The solution is to remap the stereo input to a mono input:
    1. Find your source name from the following command; mine is alsa_input.pci-0000_00_1f.3.analog-stereo
    pacmd list-sources | grep 'name:.*input'
    2. Edit /etc/pulse/default.pa and add the following lines, where INPUT_NAME is name of the input source from above step:
    load-module module-remap-source source_name=record_mono master=INPUT_NAME master_channel_map=front-left channel_map=mono
    set-default-source record_mono
    3. Restart PulseAudio:
    $ pulseaudio -k
    $ pulseaudio --start
    Now arecord hopefully works. You may still need to change the RecordStream from setting to Remapped Built-in Audio Analog Stereo of a specific application in the Recording tab of pavucontrol.

    Como podem ver, estou bem ferrado e agradeço muito qualquer ajuda. Valeu mesmo pessoal!
Entre ou Registre-se para fazer um comentário.