[Resolvido] Problema com resolução no notebook

Formatei o meu notebook que tinha o windows 7 e coloquei o linux mint. Nunca tinha experimentado o linux e fiz isso pra tentar "ressuscitar" o notebook que já está bem velhinho. Fiz os procedimentos padrão para instalar o linux - usando um pendrive bootado - e na tela de "pré-instalação" do linux de fato a resolução estava perfeita, porém após clicar no disco que instalava o sistema completo e o processo estar terminado a resolução mudou e agora tudo está muito grande. Não da pra usar a maquina de uma forma decente.
Já procurei resposta em alguns sites mas não achei um problema igual o meu, já tentei mudar pelo painel de preferências na aba Monitor mas lá só aparece a resolução que já está aplicada. Já tentei pelo terminal aplicando o comando xrandr, mas só aparece:

~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected primary 640x480+0+0 0mm x 0mm
640x480 73.00*

Pelos fóruns que eu vi precisava aparecer pelo menos o nome no monitor ou o tipo de conexão para tentar algo, mas como podem ver não aparece.

Sou iniciante nesse tipo de sistema e, se possível, gostaria de uma solução detalhada para meu problema.
Post edited by welblade on

Comentários

  • Execute o comando abaixo e copie e cole a saída no tópico:

    inxi -Fxxxz


    Notebook Avell B153 PLUS

    Linux Mint 19.3 Tricia
    Processor: Intel Core i5-4200M
    Memory: 8 GB RAM
    Graphics: NVIDIA GK208M [GeForce GT 730M]
    Kernel: 5.5.0-15.1-liquorix-amd64 x86_64
  • System:
    Host: george-Positivo-Mobile Kernel: 5.3.0-46-generic i686 bits: 32
    compiler: gcc v: 7.5.0 Desktop: Cinnamon 4.4.8 wm: muffin 4.4.2
    dm: LightDM 1.26.0 Distro: Linux Mint 19.3 Tricia
    base: Ubuntu 18.04 bionic
    Machine:
    Type: Other-vm? System: Positivo product: Positivo Mobile
    v: 1.00.13PO_CAIXA serial: Chassis: SiS type: 1
    serial:
    Mobo: clevo model: M7x0S v: Bottom serial: BIOS: Phoenix
    v: 6.00 date: 05/01/2009
    Battery:
    ID-1: BAT0 charge: 1.9 Wh condition: 23.5/47.5 Wh (49%) volts: 14.8/10.8
    model: NOTEBOOK BAT1 type: Li-ion serial: status: Charging
    CPU:
    Topology: Dual Core model: Intel Pentium Dual T3400 bits: 64 type: MCP
    arch: Core Merom rev: D L2 cache: 1024 KiB
    flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 8669
    Speed: 1848 MHz min/max: 1000/2167 MHz Core speeds (MHz): 1: 1848
    2: 1794
    Graphics:
    Device-1: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display
    Adapter
    vendor: CLEVO/KAPOK driver: N/A bus ID: 01:00.0 chip ID: 1039:6351
    Display: x11 server: X.Org 1.20.5 driver: fbdev
    unloaded: modesetting,vesa alternate: sis resolution: 640x480~73Hz
    OpenGL: renderer: llvmpipe (LLVM 9.0 128 bits) v: 3.3 Mesa 19.2.8
    compat-v: 3.1 direct render: Yes
    Audio:
    Device-1: Silicon Integrated Systems [SiS] Azalia Audio
    vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel bus ID: 00:0f.0
    chip ID: 1039:7502
    Sound Server: ALSA v: k5.3.0-46-generic
    Network:
    Device-1: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter
    vendor: CLEVO/KAPOK driver: sis190 v: 1.4 port: 1000 bus ID: 00:04.0
    chip ID: 1039:0191
    IF: enp0s4 state: down mac:
    Device-2: Realtek RTL8187B Wireless 802.11g 54Mbps Network Adapter
    type: USB driver: rtl8187 bus ID: 1-2:2 chip ID: 0bda:8189
    serial:
    IF: wlx002243930b87 state: up mac:
    Drives:
    Local Storage: total: 149.05 GiB used: 14.13 GiB (9.5%)
    ID-1: /dev/sda vendor: Seagate model: ST9160827AS size: 149.05 GiB
    speed: rotation: 5400 rpm serial: rev: A scheme: MBR
    Partition:
    ID-1: / size: 145.71 GiB used: 14.13 GiB (9.7%) fs: ext4 dev: /dev/sda1
    Sensors:
    System Temperatures: cpu: 55.0 C mobo: N/A
    Fan Speeds (RPM): N/A
    Info:
    Processes: 169 Uptime: 8m Memory: 1.64 GiB used: 812.6 MiB (48.3%)
    Init: systemd v: 237 runlevel: 5 Compilers: gcc: 7.5.0 alt: 7
    Shell: bash v: 4.4.20 running in: gnome-terminal inxi: 3.0.32

    Isso?
  • welblade disse:

    Execute o comando abaixo e copie e cole a saída no tópico:

    inxi -Fxxxz

    System:
    Host: george-Positivo-Mobile Kernel: 5.3.0-46-generic i686 bits: 32
    compiler: gcc v: 7.5.0 Desktop: Cinnamon 4.4.8 wm: muffin 4.4.2
    dm: LightDM 1.26.0 Distro: Linux Mint 19.3 Tricia
    base: Ubuntu 18.04 bionic
    Machine:
    Type: Other-vm? System: Positivo product: Positivo Mobile
    v: 1.00.13PO_CAIXA serial: Chassis: SiS type: 1
    serial:
    Mobo: clevo model: M7x0S v: Bottom serial: BIOS: Phoenix
    v: 6.00 date: 05/01/2009
    Battery:
    ID-1: BAT0 charge: 1.9 Wh condition: 23.5/47.5 Wh (49%) volts: 14.8/10.8
    model: NOTEBOOK BAT1 type: Li-ion serial: status: Charging
    CPU:
    Topology: Dual Core model: Intel Pentium Dual T3400 bits: 64 type: MCP
    arch: Core Merom rev: D L2 cache: 1024 KiB
    flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 8669
    Speed: 1848 MHz min/max: 1000/2167 MHz Core speeds (MHz): 1: 1848
    2: 1794
    Graphics:
    Device-1: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display
    Adapter
    vendor: CLEVO/KAPOK driver: N/A bus ID: 01:00.0 chip ID: 1039:6351
    Display: x11 server: X.Org 1.20.5 driver: fbdev
    unloaded: modesetting,vesa alternate: sis resolution: 640x480~73Hz
    OpenGL: renderer: llvmpipe (LLVM 9.0 128 bits) v: 3.3 Mesa 19.2.8
    compat-v: 3.1 direct render: Yes
    Audio:
    Device-1: Silicon Integrated Systems [SiS] Azalia Audio
    vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel bus ID: 00:0f.0
    chip ID: 1039:7502
    Sound Server: ALSA v: k5.3.0-46-generic
    Network:
    Device-1: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter
    vendor: CLEVO/KAPOK driver: sis190 v: 1.4 port: 1000 bus ID: 00:04.0
    chip ID: 1039:0191
    IF: enp0s4 state: down mac:
    Device-2: Realtek RTL8187B Wireless 802.11g 54Mbps Network Adapter
    type: USB driver: rtl8187 bus ID: 1-2:2 chip ID: 0bda:8189
    serial:
    IF: wlx002243930b87 state: up mac:
    Drives:
    Local Storage: total: 149.05 GiB used: 14.13 GiB (9.5%)
    ID-1: /dev/sda vendor: Seagate model: ST9160827AS size: 149.05 GiB
    speed: rotation: 5400 rpm serial: rev: A scheme: MBR
    Partition:
    ID-1: / size: 145.71 GiB used: 14.13 GiB (9.7%) fs: ext4 dev: /dev/sda1
    Sensors:
    System Temperatures: cpu: 55.0 C mobo: N/A
    Fan Speeds (RPM): N/A
    Info:
    Processes: 169 Uptime: 8m Memory: 1.64 GiB used: 812.6 MiB (48.3%)
    Init: systemd v: 237 runlevel: 5 Compilers: gcc: 7.5.0 alt: 7
    Shell: bash v: 4.4.20 running in: gnome-terminal inxi: 3.0.32
  • Com essa placa de vídeo você não deveria tentar usar o cinnamon, ela não tem aceleração 3D
    instale o ambiente mate

    apt install mint-meta-mate
    saia da sessão e quando for logar novamente, troque cinnamon por mate


    Notebook Avell B153 PLUS

    Linux Mint 19.3 Tricia
    Processor: Intel Core i5-4200M
    Memory: 8 GB RAM
    Graphics: NVIDIA GK208M [GeForce GT 730M]
    Kernel: 5.5.0-15.1-liquorix-amd64 x86_64

  • Troquei o cinnamon pelo mate e de início parecia que tinha resolvido o problema do tamanho dos icones mas quando abri os aplicativos percebi que a resolução continuava errada e só tinha a opção 640x480
    welblade disse:

    Com essa placa de vídeo você não deveria tentar usar o cinnamon, ela não tem aceleração 3D
    instale o ambiente mate

    apt install mint-meta-mate
    saia da sessão e quando for logar novamente, troque cinnamon por mate

  • agora que reparei, o sistema também não está usando nenhum driver de vídeo.
    E porque você instalou linux 32bits se seu processador é 64 bits? Isso acaba limitando o sistema, tem muitos programas que não dão suporte a 32 bits.

    sobre o driver, achei um artigo de deve ajudar, mas o driver que achei é 64 bits, então acho melhor você baixar a versão 64 bit do linux mint mate e instalar.
    Para instalar o driver depois, abra o terminal e faça o seguinte:
    cd ~/Downloads
    wget https://static.vivaolinux.com.br/imagens/artigos/comunidade/sisimedia-0.9.1.zip
    unzip sisimedia-0.9.1.zip
    sudo mv sisimedia-0.9.1/usr/lib/xorg/modules/drivers/* /usr/lib/xorg/modules/drivers/
    sudo mv sisimedia-0.9.1/etc/x11/* /etc/x11/
    Fonte: https://www.vivaolinux.com.br/artigo/Como-instalar-o-driver-da-placa-de-video-SiS-771671-no-Ubuntu-1804?pagina=2


    Notebook Avell B153 PLUS

    Linux Mint 19.3 Tricia
    Processor: Intel Core i5-4200M
    Memory: 8 GB RAM
    Graphics: NVIDIA GK208M [GeForce GT 730M]
    Kernel: 5.5.0-15.1-liquorix-amd64 x86_64
  • E lembrando que depois de tudo certo, se ainda continuar sem aparecer a resolução que vc deseja, aqui no forum tem um tutorial que ensina a configurar para essas resoluções.
  • welblade disse:

    agora que reparei, o sistema também não está usando nenhum driver de vídeo.
    E porque você instalou linux 32bits se seu processador é 64 bits? Isso acaba limitando o sistema, tem muitos programas que não dão suporte a 32 bits.

    sobre o driver, achei um artigo de deve ajudar, mas o driver que achei é 64 bits, então acho melhor você baixar a versão 64 bit do linux mint mate e instalar.
    Para instalar o driver depois, abra o terminal e faça o seguinte:

    cd ~/Downloads
    wget https://static.vivaolinux.com.br/imagens/artigos/comunidade/sisimedia-0.9.1.zip
    unzip sisimedia-0.9.1.zip
    sudo mv sisimedia-0.9.1/usr/lib/xorg/modules/drivers/* /usr/lib/xorg/modules/drivers/
    sudo mv sisimedia-0.9.1/etc/x11/* /etc/x11/
    Fonte: https://www.vivaolinux.com.br/artigo/Como-instalar-o-driver-da-placa-de-video-SiS-771671-no-Ubuntu-1804?pagina=2
    Como eu disse anteriormente, tinha acabado de trocar o windows pelo linux, não tinha preferencia por software então, em vista desse problema, troquei pelo Lubuntu. Apresentou o mesmo problema mas dessa vez eu consegui resolver.
    De qualquer forma, obrigado pela atenção.
  • Pra quem tiver interesse usei esse links:
    https://www.vivaolinux.com.br/topico/Iniciantes-no-Linux/como-arrumar-a-resolucao-da-tela-no-Lubuntu-1804
    https://ubuntuforum-br.org/index.php/topic,120588.0.html

    O meu problema era igual do primeiro link, pelo jeito que o software funciona acho que resolve no linux também.
Entre ou Registre-se para fazer um comentário.