Meu firefox pede para atualizar quando já está atualizado

Olá pessoal beleza?

Eu sigo esse tutorial para atualizar meu firefox porque o da loja do mint é 68 e a versão atual é 74.

Mas ele vive pedindo para eu o atualizar, isso é meio chato, saberiam me ajudar? Se ele pudesse atualizar sozinho como os .deb ou da loja fazem seria bom, mas eu gosto dele atualizado. Eu criei esse post pois posso estar fazendo algo errado.

Desde já Agradeço, o método que eu uso está abaixo:
Passo 1. Abra um terminal;
Passo 2. Caso já tenha feito alguma instalação manual, apague a pasta, o link e o atalho anterior com esse comando;

sudo rm -Rf /opt/firefox*

sudo rm -Rf /usr/bin/firefox

sudo rm -Rf /usr/share/applications/firefox.desktop

Passo 3. Confira se o seu sistema é de 32 bits ou 64 bits, para isso, use o seguinte comando no terminal:

uname -m

Passo 4. Se seu sistema for de 64 bits, use o comando abaixo para baixar o programa. Se o link estiver desatualizado, acesse essa página e baixe a última versão e salve-o com o nome firefox.tar.bz2:

wget "https://download.mozilla.org/?product=firefox-devedition-latest-ssl&os=linux64&lang=pt-BR" -O firefox.tar.bz2

Passo 5. Execute o comando abaixo para descomprimir o pacote baixado, para a pasta /opt/;
Passo 1. Abra um terminal;
Passo 2. Caso já tenha feito alguma instalação manual, apague a pasta, o link e o atalho anterior com esse comando;

sudo rm -Rf /opt/firefox*

sudo rm -Rf /usr/bin/firefox

sudo rm -Rf /usr/share/applications/firefox.desktop

Passo 3. Confira se o seu sistema é de 32 bits ou 64 bits, para isso, use o seguinte comando no terminal:

uname -m

Passo 4. Se seu sistema for de 64 bits, use o comando abaixo para baixar o programa. Se o link estiver desatualizado, acesse essa página e baixe a última versão e salve-o com o nome firefox.tar.bz2:

wget "https://download.mozilla.org/?product=firefox-devedition-latest-ssl&os=linux64&lang=pt-BR" -O firefox.tar.bz2

Passo 5. Execute o comando abaixo para descomprimir o pacote baixado, para a pasta /opt/;

sudo tar -jxvf  firefox.tar.bz2 -C /opt/

Passo 6. Renomeie a pasta criada. Se ao executar o comando abaixo ocorrer um erro com a mensagem iniciando com “mv: é impossível sobrescrever o não-diretório”, pule este passo;

sudo mv /opt/firefox*/ /opt/firefox

Passo 7. Finalmente, crie um atalho para facilitar a execução do programa;

sudo ln -sf /opt/firefox/firefox /usr/bin/firefox

Passo 8. Se seu ambiente gráfico atual suportar, crie um lançador para o Firefox, usando comando abaixo;

echo -e '[Desktop Entry]\n Version=74.0.1\n Encoding=UTF-8\n Name=Mozilla Firefox\n Comment=Navegador Web\n Exec=/opt/firefox/firefox\n Icon=/opt/firefox/browser/chrome/icons/default/default128.png\n Type=Application\n Categories=Network' | sudo tee /usr/share/applications/firefox.desktop

Pronto! Agora, quando quiser iniciar o programa, digite firefox em um terminal, seguido da tecla TAB.

Já se a sua distribuição suportar, coloque o atalho na sua área de trabalho usando o gerenciador de arquivos do sistema ou o comando abaixo, e use-o para iniciar o programa.

sudo chmod +x /usr/share/applications/firefox.desktop

cp /usr/share/applications/firefox.desktop  ~/Área\ de\ Trabalho/

Se seu sistema estiver em inglês, use este comando para copiar o atalho para sua área de trabalho:

cp /usr/share/applications/firefox.desktop ~/Desktop

Para mais detalhes sobre essa tarefa, consulte esse tutorial:
Como adicionar atalhos de aplicativos na área de trabalho do Unity

Se quiser, você também pode usar o gerenciador de arquivos do sistema para executar o programa, apenas abrindo a pasta dele e clicando em seu executável.

Se você usa Ubuntu e quer apenas atualizar o Firefox, veja esse outro tutorial:
Firefox:veja como atualizar para a última versão no Ubuntu
Como remover o Firefox no Linux

Para remover o Firefox Edition no Linux, basta apagar a pasta, o link e o atalho anterior com esse comando;

sudo rm -Rf /opt/firefox*

sudo rm -Rf /usr/bin/firefox

sudo rm -Rf /usr/share/applications/firefox.desktop
sudo tar -jxvf  firefox.tar.bz2 -C /opt/

Passo 6. Renomeie a pasta criada. Se ao executar o comando abaixo ocorrer um erro com a mensagem iniciando com “mv: é impossível sobrescrever o não-diretório”, pule este passo;

sudo mv /opt/firefox*/ /opt/firefox

Passo 7. Finalmente, crie um atalho para facilitar a execução do programa;

sudo ln -sf /opt/firefox/firefox /usr/bin/firefox

Passo 8. Se seu ambiente gráfico atual suportar, crie um lançador para o Firefox, usando comando abaixo;

echo -e '[Desktop Entry]\n Version=74.0.1\n Encoding=UTF-8\n Name=Mozilla Firefox\n Comment=Navegador Web\n Exec=/opt/firefox/firefox\n Icon=/opt/firefox/browser/chrome/icons/default/default128.png\n Type=Application\n Categories=Network' | sudo tee /usr/share/applications/firefox.desktop

Pronto! Agora, quando quiser iniciar o programa, digite firefox em um terminal, seguido da tecla TAB.

Já se a sua distribuição suportar, coloque o atalho na sua área de trabalho usando o gerenciador de arquivos do sistema ou o comando abaixo, e use-o para iniciar o programa.

sudo chmod +x /usr/share/applications/firefox.desktop

cp /usr/share/applications/firefox.desktop  ~/Área\ de\ Trabalho/

Se seu sistema estiver em inglês, use este comando para copiar o atalho para sua área de trabalho:

cp /usr/share/applications/firefox.desktop ~/Desktop

Para mais detalhes sobre essa tarefa, consulte esse tutorial:
Como adicionar atalhos de aplicativos na área de trabalho do Unity

Se quiser, você também pode usar o gerenciador de arquivos do sistema para executar o programa, apenas abrindo a pasta dele e clicando em seu executável.

Se você usa Ubuntu e quer apenas atualizar o Firefox, veja esse outro tutorial:
Firefox:veja como atualizar para a última versão no Ubuntu
Como remover o Firefox no Linux

Para remover o Firefox Edition no Linux, basta apagar a pasta, o link e o atalho anterior com esse comando;

sudo rm -Rf /opt/firefox*

sudo rm -Rf /usr/bin/firefox

sudo rm -Rf /usr/share/applications/firefox.desktop
OS: LMDE 4 Debbie x86_64
Model: A320MH
Kernel: 4.9.0-11-amd64
Shell: zsh 5.7.1 (x86_64-debian-linux-gnu)
DE: Cinnamon 4.4.8
CPU: AMD Ryzen 3 2200G (4) @ 3.5GHz
GPU: AMD Radeon RX 460
Memory: 2462MB / 7932MB

Comentários

  • editado 6 de April
    Primeiro, qual versão do linux mint você está usando?
    Se for menor que 19, você deveria considerar atualizar pra versão atual, assim vai ter a versão estável mais atual dos programas.

    Segundo, ou você copiou esse tutorial errado ou ele é uma bagunça :D

    É claro que ele vai pedir pra atualizar e não vai conseguir, porque está com a atualização automática habilitada e está instalado na pasta do sistema, ele vai sempre baixar a versão mais nova, mas não vai instalá-la porque não tem permissão.

    Você não precisava instalar ele na pasta de sistema, podia apenas colocar em uma pasta na Home ou na pasta download mesmo, depois só cria um atalho pra ele.

    Mas repito, você deve estar usando uma versão antiga do mint, seria bom atualizar.
    Post edited by welblade on


    Notebook Avell B153 PLUS

    Linux Mint 19.3 Tricia
    Processor: Intel Core i5-4200M
    Memory: 8 GB RAM
    Graphics: NVIDIA GK208M [GeForce GT 730M]
    Kernel: 5.5.0-15.1-liquorix-amd64 x86_64
  • welblade disse:

    Primeiro, qual versão do linux mint você está usando?
    Se for menor que 19, você deveria considerar atualizar pra versão atual, assim vai ter a versão estável mais atual dos programas.

    Segundo, ou você copiou esse tutorial errado ou ele é uma bagunça :D

    É claro que ele vai pedir pra atualizar e não vai conseguir, porque está com a atualização automática habilitada e está instalado na pasta do sistema, ele vai sempre baixar a versão mais nova, mas não vai instalá-la porque não tem permissão.

    Você não precisava instalar ele na pasta de sistema, podia apenas colocar em uma pasta na Home ou na pasta download mesmo, depois só cria um atalho pra ele.

    Mas repito, você deve estar usando uma versão antiga do mint, seria bom atualizar.

    O meu mint é o Debian Edition LMD3

    OS: LMDE 3 Cindy x86_64
    Model: A320MH
    Kernel: 4.9.0-12-amd64

    Ok, eu vou ver outras opções de instalação, eu estou aprendendo como instalar os programas sem usar a loja.
    OS: LMDE 4 Debbie x86_64
    Model: A320MH
    Kernel: 4.9.0-11-amd64
    Shell: zsh 5.7.1 (x86_64-debian-linux-gnu)
    DE: Cinnamon 4.4.8
    CPU: AMD Ryzen 3 2200G (4) @ 3.5GHz
    GPU: AMD Radeon RX 460
    Memory: 2462MB / 7932MB
  • editado 9 de April
    sempre que puder evite instalar programas fora da loja, só use em ultima opção, fora da loja de preferência pra flatpak ou appimage.

    Quando ao seu mint, já saiu a versão 4 do lmde, com várias melhorias, você pode atualizar

    https://community.linuxmint.com/tutorial/view/2475
    Post edited by welblade on


    Notebook Avell B153 PLUS

    Linux Mint 19.3 Tricia
    Processor: Intel Core i5-4200M
    Memory: 8 GB RAM
    Graphics: NVIDIA GK208M [GeForce GT 730M]
    Kernel: 5.5.0-15.1-liquorix-amd64 x86_64
  • welblade disse:

    sempre que puder evite instalar programas fora da loja, só use em ultima opção, fora da loja de preferência pra flatpak ou appimage.

    Quando ao seu mint, já saiu a versão 4 do lmde, com várias melhorias, você pode atualizar

    https://community.linuxmint.com/tutorial/view/2475

    É que o firefox do site da mozilla é mais atualizado 74 e o da loja é lts 68. Vou fazer um backup aqui e atualizar.
    OS: LMDE 4 Debbie x86_64
    Model: A320MH
    Kernel: 4.9.0-11-amd64
    Shell: zsh 5.7.1 (x86_64-debian-linux-gnu)
    DE: Cinnamon 4.4.8
    CPU: AMD Ryzen 3 2200G (4) @ 3.5GHz
    GPU: AMD Radeon RX 460
    Memory: 2462MB / 7932MB
  • Só como referência, você pode instalar o firefox ou appimage ou a flatpak

    appimage é só baixar, dar permissão de execução e executar
    https://www.appimagehub.com/p/1331794

    no pacote flatpak, você precisa instalar o flatpak primeiro
    https://flathub.org/apps/details/org.mozilla.firefox

    https://flatpak.org/setup/Debian/


    Notebook Avell B153 PLUS

    Linux Mint 19.3 Tricia
    Processor: Intel Core i5-4200M
    Memory: 8 GB RAM
    Graphics: NVIDIA GK208M [GeForce GT 730M]
    Kernel: 5.5.0-15.1-liquorix-amd64 x86_64
Entre ou Registre-se para fazer um comentário.