[RESOLVIDO] Não foi possível baixar todos os índices de repositórios

Eai galera, estou tendo esse problema abaixo no meu linux, sou novo nesse sistema.

O repositório pode não estar mais disponível ou pode não ter sido possível entrar em contato com o mesmo devido a problemas de rede. Caso esteja disponível, uma versão mais antiga do índice que falhou será usada. Senão o repositório será ignorado. Verifique sua conexão de rede e certifique-se de que o endereço do repositório esteja correto nas preferências.

E: Tipo 'sudo' não é conhecido na linha 1 na lista de fontes /etc/apt/sources.list.d/mono-official-vs.list
E: Incapaz de obter o lock do diretório de listas

Configure as opções de repositórios para corrigir o problema.
E: _cache->open() failed, please report.

Como faço para arrumar isso aqui ?

Agradeço desde de já.
Post edited by welblade on

Comentários

  • editado 23 de março
    Você deve ter feito algum comando errado quando estava criando o arquivo mono-official-vs.list.
    remove esse arquivo e crie novamente:

    sudo rm /etc/apt/sources.list.d/mono-official-vs.list

    depois:
    apt install gnupg ca-certificates
    sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
    echo "deb https://download.mono-project.com/repo/ubuntu vs-bionic main" | sudo tee /etc/apt/sources.list.d/mono-official-vs.list
    apt update


    se bem que não entendo por que você está instalando essa coisa :D
    Post edited by welblade on


    Notebook Avell B153 PLUS

    Linux Mint 19.3 Tricia
    Processor: Intel Core i5-4200M
    Memory: 8 GB RAM
    Graphics: NVIDIA GK208M [GeForce GT 730M]
    Kernel: 5.5.0-8.1-liquorix-amd64 x86_64
  • Muito Obrigado, ajudou muito.
  • Prezados, boa tarde. Estou tendo problemas para instalar alguns programas via Gerenciador de Aplicativos. O VirtualBox, por exemplo, falha o download de algumas bibliotecas e solicita verificar a conexão de rede. O erro se repete em qualquer rede a que eu esteja conectado. Estou usando o Mint 19.3 (Tricia), MATE Edition 1.22.2. Obrigado
  • procure o programa fontes de aplicativos, e tente mudar os servidores (mirrors) principal e base


    Notebook Avell B153 PLUS

    Linux Mint 19.3 Tricia
    Processor: Intel Core i5-4200M
    Memory: 8 GB RAM
    Graphics: NVIDIA GK208M [GeForce GT 730M]
    Kernel: 5.5.0-8.1-liquorix-amd64 x86_64
Entre ou Registre-se para fazer um comentário.