Problemas com áudio - Mint 19.3 - Som de saída Microfone

Olá, bom dia. Tudo bem?

Meu nome é André, e já uso o Linux há muito tempo, mas sempre que surgia um problema eu voltava para o Windows rs. Só que vim para ficar, eu acho rs, pois meu o Windows 10 deu pau no meu notebook e o Linux Mint está rodando redondo demais. :)

Apanhei um pouco, mas o sistema está como eu quero, com exceção do Som. :( A reprodução está ruim, com som abafado, e a captação, por microfone, com som muito baixo. Já li alguns tutoriais, tentei mexer mas não consegui. Quando aumento a captação do microfone no Pulse, o som distorce e continua baixo...

Eu testei com o microfone interno do notebook, microfone da Webcam USB da Logitech C920 Pro e do Microfone de lapela da Sony ECM-CS3. Todos são reconhecidos pelo Linux, mas com o mesmo problema (captação baixa) e qualidade diferente.

Aabaixo colo o resultado do inxi -F:

[email protected] ~ $ inxi -F
System:
Host: Notebook-Andre Kernel: 5.3.0-28-generic x86_64 bits: 64
Desktop: Cinnamon 4.4.8 Distro: Linux Mint 19.3 Tricia
Machine:
Type: Laptop System: Hewlett-Packard product: HP Pavilion 14 Notebook PC
v: 0976100000405F10000610180 serial:
Mobo: Hewlett-Packard model: 2280 v: 77.35 serial:
UEFI: Insyde v: F.57 date: 11/09/2018
Battery:
ID-1: BAT0 charge: 24.2 Wh condition: 24.2/24.2 Wh (100%)
CPU:
Topology: Dual Core model: Intel Core i5-4210U bits: 64 type: MT MCP
L2 cache: 3072 KiB
Speed: 1169 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 1226 2: 1337
3: 1294 4: 1276
Graphics:
Device-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel
Device-2: NVIDIA GM108M [GeForce 830M] driver: N/A
Display: x11 server: X.Org 1.19.6 driver: modesetting
unloaded: fbdev,vesa resolution: 1366x768~60Hz
OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 19.2.8
Audio:
Device-1: Intel Haswell-ULT HD Audio driver: snd_hda_intel
Device-2: Intel 8 Series HD Audio driver: snd_hda_intel
Sound Server: ALSA v: k5.3.0-28-generic
Network:
Device-1: Intel Wireless 3160 driver: iwlwifi
IF: wlan0 state: up mac: a0:88:69:cc:b3:39
Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
IF: eth0 state: down mac: 8c:dc:d4:fe:5d:3c
Drives:
Local Storage: total: 931.51 GiB used: 364.54 GiB (39.1%)
ID-1: /dev/sda vendor: Seagate model: ST1000LM024 HN-M101MBB
size: 931.51 GiB
Partition:
ID-1: / size: 46.81 GiB used: 20.14 GiB (43.0%) fs: ext4 dev: /dev/sda6
ID-2: /home size: 215.53 GiB used: 90.76 GiB (42.1%) fs: ext4
dev: /dev/sda7
ID-3: swap-1 size: 3.77 GiB used: 29.8 MiB (0.8%) fs: swap dev: /dev/sda9
Sensors:
System Temperatures: cpu: 59.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 277 Uptime: 22h 29m Memory: 7.71 GiB used: 3.49 GiB (45.2%)
Shell: bash inxi: 3.0.32

Eu já mexi no Pulse Aúdio, Alsa-mixer e nada. Eu prefiro desinstalar tudo e instalar corretamente, com a ajuda de algúem experiente nisso, por favor. :)

Muito obrigado!
·
«1

Comentários

  • editado 7 de fevereiro
    Você pode tentar melhorar a configuração padrão de áudio, abre o terminal e digita o comando abaixo

    xed ~/.config/pulse/daemon.conf

    provavelmente o arquivo vai estar vazio, ai você copia e cola o conteúdo abaixo:

    default-sample-format = s32le
    default-sample-rate = 48000
    alternate-sample-rate = 192000
    default-sample-channels = 2
    default-channel-map = front-left,front-right
    default-fragments = 2
    default-fragment-size-msec = 125
    resample-method = speex-float-5
    enable-lfe-remixing = no
    high-priority = yes
    nice-level = -11
    realtime-scheduling = yes
    realtime-priority = 9
    rlimit-rtprio = 9
    daemonize = no


    salva o arquivo e reinicia o pc

    Peguei essa configuração aqui:
    https://medium.com/@gamunu/enable-high-quality-audio-on-linux-6f16f3fe7e1f
    Post edited by welblade on


    Notebook Avell B153 PLUS

    Linux Mint 19.3 Tricia
    Processor: Intel Core i5-4200M
    Memory: 8 GB RAM
    Graphics: NVIDIA GK208M [GeForce GT 730M]
    Kernel: 5.5.0-5.2-liquorix-amd64 x86_64
    ·
  • editado 7 de fevereiro
    welblade disse:

    Você pode tentar melhorar a configuração padrão de áudio, abre o terminal e digita o comando abaixo

    xed ~/.config/pulse/daemon.conf

    provavelmente o arquivo vai estar vazio, ai você copia e cola o conteúdo abaixo:

    default-sample-format = s32le
    default-sample-rate = 48000
    alternate-sample-rate = 44100
    default-sample-channels = 2
    default-channel-map = front-left,front-right
    default-fragments = 2
    default-fragment-size-msec = 125
    resample-method = speex-float-5
    enable-lfe-remixing = no
    high-priority = yes
    nice-level = -11
    realtime-scheduling = yes
    realtime-priority = 9
    rlimit-rtprio = 9
    daemonize = no


    salva o arquivo e reinicia o pc.

    Peguei essa configuração aqui:
    https://medium.com/@gamunu/enable-high-quality-audio-on-linux-6f16f3fe7e1f

    Obrigado welblade!Já salvei o arquivo e vou reiniciar para testar!
    Post edited by welblade on
    ·
  • Olá. Testei a saída de som, mas continua abafada... E o microfone muito baixo, a mesma coisa. :(
    ·
  • editado 6 de fevereiro
    tenta mais uma coisa, no terminal
    xed ~/.asoundrc

    e cola esse conteúdo nele, salva, reinicia o pc


    pcm.!default {
    type plug
    slave.pcm hw
    }
    Post edited by welblade on


    Notebook Avell B153 PLUS

    Linux Mint 19.3 Tricia
    Processor: Intel Core i5-4200M
    Memory: 8 GB RAM
    Graphics: NVIDIA GK208M [GeForce GT 730M]
    Kernel: 5.5.0-5.2-liquorix-amd64 x86_64
    ·
  • welblade disse:

    tenta mais uma coisa, no terminal
    xed ~/.asoundrc

    e cola esse conteúdo nele, salva, reinicia o pc


    pcm.!default {
    type plug
    slave.pcm hw
    }

    Opa Welblade, show cara!! A captura de som está top agora. :) Só a saída de som que está abafada ainda :(.

    Tem alguma ideia?
    ·
  • editado 7 de fevereiro
    Não sei se isso chega a ajudar mas eu deixei duas linhas erradas no arquivo
    ~/.config/pulse/daemon.conf

    default-sample-format = float32le
    e
    resample-method = soxr-vhq

    troca, respectivamente, para

    default-sample-format = s32le
    e
    resample-method = speex-float-5

    vou até arrumar no post anterior, para caso alguém usar, não copiar errado
    Post edited by welblade on


    Notebook Avell B153 PLUS

    Linux Mint 19.3 Tricia
    Processor: Intel Core i5-4200M
    Memory: 8 GB RAM
    Graphics: NVIDIA GK208M [GeForce GT 730M]
    Kernel: 5.5.0-5.2-liquorix-amd64 x86_64
    ·
  • e adiciona essa conteudo ao final do aquivo ~/.asoundrc

    ctl.!default {
    type hw
    card PCH
    }


    Notebook Avell B153 PLUS

    Linux Mint 19.3 Tricia
    Processor: Intel Core i5-4200M
    Memory: 8 GB RAM
    Graphics: NVIDIA GK208M [GeForce GT 730M]
    Kernel: 5.5.0-5.2-liquorix-amd64 x86_64
    ·
  • Bom dia Welblade. Em primeiro lugar, muito obrigado pela sua ajuda. :)

    A captura de som fica muito baixa quando uso PulseAudio como o backend. Mudando para Alsa, o som fica bom. Ante não ficava. "Só isso" já me ajudou muito, muito obrigado!

    Mas a saída de som ainda está abafada... Mas não me incomoda muito. Só queria saber configurar para ficar tudo certinho...

    Você acha que vale a pena remover todos os drivers (não sei como se chama no linux) - pulse, alsa etc e depois reinstalar somente um?

    Muito obrigado!!!
    ·
  • editado 7 de fevereiro
    Desaconselho a desinstalar o pulse, pode quebrar o Sistema.

    é estranho continuar abafado é como se sua placa tivesse configurada para ficar em baixa qualidade.
    As configurações que eu te mandei faziam duas coisas, aumentar a qualidade do áudio e colocar para se comunicar diretamente com o hardware como padrão.

    Tem um programa que eu uso, chamado pulseeffects, entre varias coisas ele tem equalizador, compressor, e modos de aumentar o ganho. tanto da entrada quanto saída de áudio, você deveria testar.

    Já que alsa funciona bem pra você você pode instalar o apulse, que serve para você usar o alsa em programas que só funciona com o pulse.

    Você pode dar uma pesquisada em como instalar e usar eles pela net.
    Post edited by welblade on


    Notebook Avell B153 PLUS

    Linux Mint 19.3 Tricia
    Processor: Intel Core i5-4200M
    Memory: 8 GB RAM
    Graphics: NVIDIA GK208M [GeForce GT 730M]
    Kernel: 5.5.0-5.2-liquorix-amd64 x86_64
    ·
  • Obrigado, vou verificar :)
    ·
Entre ou Registre-se para fazer um comentário.