(RESOLVIDO)não consigo atualizar

quanto tento atualizar aparece a seguinte mensagem
"A preparar para desempacotar .../python3-apt_1.6.5ubuntu0.2_amd64.deb ...
A descompactar python3-apt (1.6.5ubuntu0.2) sobre (1.6.5ubuntu0.1) ...
dpkg-deb (sub-processo): a descomprimir membro do arquivo: erro de lzma: os dados comprimidos estão corrompidos
dpkg-deb: erro: subprocess returned error exit status 2
dpkg: erro ao processar o arquivo /var/cache/apt/archives/python3-apt_1.6.5ubuntu0.2_amd64.deb (--unpack):
não pode copiar dados extráidos para './usr/lib/python3/dist-packages/apt_pkg.cpython-36m-x86_64-linux-gnu.so' para '/usr/lib/python3/dist-packages/apt_pkg.cpython-36m-x86_64-linux-gnu.so.dpkg-new': fim de ficheiro ou stream inesperado
Erros foram encontrados durante o processamento de:
/var/cache/apt/archives/python3-apt_1.6.5ubuntu0.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)"
Post edited by lucascb32 on
·

Comentários

  • Quando eu esse tipo de problema eu resolvo com esse pequeno comando aqui.


    sudo rm -Rf /var/lib/apt/lists/* ; sudo rm -Rf /var/lib/apt/lists/* ; sudo mkdir -p /var/lib/apt/lists/partial/* sudo rm -Rf /var/lib/apt/lists/partial/* ; sudo rm -r /var/lib/apt/lists/partial/* ; sudo rm -r /var/lib/apt/lists/* -vf ; sudo apt-get -f install ; sudo apt-get clean ; sudo apt update ; sudo dpkg --configure -a ; sudo apt dist-upgrade ; sudo apt-get clean ; sudo apt-get autoremove ; sudo apt-get autoclean

    Só basta copiar tudo e cola no terminal.
    ·
  • Funcionou obrigado
    ·
Entre ou Registre-se para fazer um comentário.