[Resolvido] Driver de video no Linux Mint

editado 9 de agosto em Dúvidas Iniciais
Fala galera tudo beleza?
Sou novato no Linux Mint, 2o dia apanhando pra caramba, hehehe. Instalei ontem o Linux Mint no meu PC novo e gostaria de atualizar o driver de vídeo. No caso estou usando um Ryzen 5 3400G que vem com uma Radeon Vega 11 mas não consigo localizar nada a respeito de atualização de drivers de vídeo em ambiente Linux. Porém o próprio sistema pede para que eu atualize através do gerenciador de drivers, mas nem ele detecta o que deve ser atualizado.
Como funciona essa parte no Linux?
Obrigado, abs. Papo.
Post edited by Alquintela on
·
«1

Comentários

  • Se você quiser utilizar um hardware AMD muito recente, você precisará de um kernel linux recente.

    Acesse: https://linuxmint.com.br/discussion/51620/instalando-o-hwe-kernel-5-0-xorg-1-20-no-mint-19-x
    ·
  • Obrigado pela resposta dougpess
    fiz a atualização do Kernel e reiniciei o micro normalmente
    Mas ainda não sei como instalar o driver, se tenho que baixar alguma coisa ou dar algum comando no terminal. O gerenciador de drivers não tem nada ainda.
    Vlw abs
    ·
  • Papo disse:

    Obrigado pela resposta dougpess
    fiz a atualização do Kernel e reiniciei o micro normalmente
    Mas ainda não sei como instalar o driver, se tenho que baixar alguma coisa ou dar algum comando no terminal. O gerenciador de drivers não tem nada ainda.
    Vlw abs

    Os drives já vem junto com o Kernel amigo, se você já atualizou o kernel os drive já foram atualizados junto.

    ·
  • Posta aqui o resultado do comando.

    inxi -FxZ

    Para que a gente de uma olhada melhor.
    ·
  • Ok Francis, lá vai:

    [email protected]:~$ inxi -FxZ
    System:
    Host: r5 Kernel: 5.0.0-23-generic x86_64 bits: 64 compiler: gcc v: 7.4.0
    Desktop: Cinnamon 4.2.3 Distro: Linux Mint 19.2 Tina
    base: Ubuntu 18.04 bionic
    Machine:
    Type: Desktop Mobo: ASRock model: B450M-HDV R4.0 serial:
    UEFI [Legacy]: American Megatrends v: P3.10 date: 07/18/2019
    CPU:
    Topology: Quad Core model: AMD Ryzen 5 3400G with Radeon Vega Graphics
    bits: 64 type: MT MCP arch: Zen rev: 1 L2 cache: 2048 KiB
    flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
    bogomips: 59086
    Speed: 1402 MHz min/max: 1400/3700 MHz Core speeds (MHz): 1: 1397 2: 1397
    3: 1397 4: 1397 5: 1396 6: 1397 7: 1385 8: 1393
    Graphics:
    Device-1: AMD Picasso driver: amdgpu v: kernel bus ID: 08:00.0
    Display: x11 server: X.Org 1.20.4 driver: amdgpu,ati
    unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz
    OpenGL: renderer: AMD RAVEN (DRM 3.27.0 5.0.0-23-generic LLVM 8.0.0)
    v: 4.5 Mesa 19.0.2 direct render: Yes
    Audio:
    Device-1: AMD driver: snd_hda_intel v: kernel bus ID: 08:00.1
    Device-2: AMD vendor: ASRock driver: snd_hda_intel v: kernel
    bus ID: 08:00.6
    Sound Server: ALSA v: k5.0.0-23-generic
    Network:
    Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: r8169 v: kernel port: f000 bus ID: 07:00.0
    IF: enp7s0 state: up speed: 100 Mbps duplex: full mac: 70:85:c2:b9:91:65
    Drives:
    Local Storage: total: 1.35 TiB used: 790.48 GiB (57.3%)
    ID-1: /dev/sda vendor: Western Digital model: WDS480G2G0A-00JH30
    size: 447.14 GiB
    ID-2: /dev/sdb vendor: Samsung model: HD103SJ size: 931.51 GiB
    Partition:
    ID-1: / size: 438.17 GiB used: 272.59 GiB (62.2%) fs: ext4 dev: /dev/dm-0
    ID-2: swap-1 size: 976.0 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1
    Sensors:
    System Temperatures: cpu: 29.5 C mobo: N/A gpu: amdgpu temp: 29 C
    Fan Speeds (RPM): N/A
    Info:
    Processes: 248 Uptime: 2h 57m Memory: 5.74 GiB used: 2.61 GiB (45.5%)
    Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20
    inxi: 3.0.32
    [email protected]:~$
    ·
  • editado 5 de agosto
    Papo disse:

    Ok Francis, lá vai:

    [email protected]:~$ inxi -FxZ
    System:
    Host: r5 Kernel: 5.0.0-23-generic x86_64 bits: 64 compiler: gcc v: 7.4.0
    Desktop: Cinnamon 4.2.3 Distro: Linux Mint 19.2 Tina
    base: Ubuntu 18.04 bionic
    Machine:
    Type: Desktop Mobo: ASRock model: B450M-HDV R4.0 serial:
    UEFI [Legacy]: American Megatrends v: P3.10 date: 07/18/2019
    CPU:
    Topology: Quad Core model: AMD Ryzen 5 3400G with Radeon Vega Graphics
    bits: 64 type: MT MCP arch: Zen rev: 1 L2 cache: 2048 KiB
    flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
    bogomips: 59086
    Speed: 1402 MHz min/max: 1400/3700 MHz Core speeds (MHz): 1: 1397 2: 1397
    3: 1397 4: 1397 5: 1396 6: 1397 7: 1385 8: 1393
    Graphics:
    Device-1: AMD Picasso driver: amdgpu v: kernel bus ID: 08:00.0
    Display: x11 server: X.Org 1.20.4 driver: amdgpu,ati
    unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz
    OpenGL: renderer: AMD RAVEN (DRM 3.27.0 5.0.0-23-generic LLVM 8.0.0)
    v: 4.5 Mesa 19.0.2 direct render: Yes
    Audio:
    Device-1: AMD driver: snd_hda_intel v: kernel bus ID: 08:00.1
    Device-2: AMD vendor: ASRock driver: snd_hda_intel v: kernel
    bus ID: 08:00.6
    Sound Server: ALSA v: k5.0.0-23-generic
    Network:
    Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: r8169 v: kernel port: f000 bus ID: 07:00.0
    IF: enp7s0 state: up speed: 100 Mbps duplex: full mac: 70:85:c2:b9:91:65
    Drives:
    Local Storage: total: 1.35 TiB used: 790.48 GiB (57.3%)
    ID-1: /dev/sda vendor: Western Digital model: WDS480G2G0A-00JH30
    size: 447.14 GiB
    ID-2: /dev/sdb vendor: Samsung model: HD103SJ size: 931.51 GiB
    Partition:
    ID-1: / size: 438.17 GiB used: 272.59 GiB (62.2%) fs: ext4 dev: /dev/dm-0
    ID-2: swap-1 size: 976.0 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1
    Sensors:
    System Temperatures: cpu: 29.5 C mobo: N/A gpu: amdgpu temp: 29 C
    Fan Speeds (RPM): N/A
    Info:
    Processes: 248 Uptime: 2h 57m Memory: 5.74 GiB used: 2.61 GiB (45.5%)
    Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20
    inxi: 3.0.32
    [email protected]:~$
    Olha aqui.

    Graphics: Device-1: AMD Picasso driver: amdgpu v: kernel bus ID: 08:00.0
    Display: x11 server: X.Org 1.20.4 driver: amdgpu,ati
    unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz
    OpenGL: renderer: AMD RAVEN (DRM 3.27.0 5.0.0-23-generic LLVM 8.0.0)
    v: 4.5 Mesa 19.0.2 direct render: Yes

    Seus Drives estão instalados, ainda não entendi e atualizados ainda não entendi oque você esta querendo fazer.
    Você esta endo algum problema com sua placa de video?

    Post edited by Francis on
    ·
  • Na verdade eu só queria atualizar o driver do vídeo, pois o próprio sistema alertava a respeito da falta de driver para vídeo. Eu não sabia que atualizando o Kernel atualizava os drivers automaticamente. Eu venho do Windows, depois de 3 décadas usando plataforma Microsoft o Linux parece ser bem diferente em muitos aspectos e preciso me familiarizar melhor com os conceitos dele. Estou ainda no 3o dia de uso e ainda fico muito confuso principalmente com os comandos via terminal.
    Mas valeu pela força, o problema parece resolvido, pelo menos até o momento.
    Agora é continuar pesquisando e aprendendo a respeito.
    Abs
    ·
  • Papo disse:

    Na verdade eu só queria atualizar o driver do vídeo, pois o próprio sistema alertava a respeito da falta de driver para vídeo. Eu não sabia que atualizando o Kernel atualizava os drivers automaticamente. Eu venho do Windows, depois de 3 décadas usando plataforma Microsoft o Linux parece ser bem diferente em muitos aspectos e preciso me familiarizar melhor com os conceitos dele. Estou ainda no 3o dia de uso e ainda fico muito confuso principalmente com os comandos via terminal.
    Mas valeu pela força, o problema parece resolvido, pelo menos até o momento.
    Agora é continuar pesquisando e aprendendo a respeito.
    Abs

    Minha maquina nova acabou de chega e ela também é Vega 11 e olha o Gerenciador de Drive.



    Não apresenta erro algum e nem nada. Ou seja já esta tudo instalado.

    Tira um print ai do seu Gerenciador de Drives e posta aqui pra nos da uma olhada nele e ver oque esta acontecendo.

    Sobre os drives, os drives para linux são Opensources ou seja livre, abertos assim já vem junto com o kernel e é instalado automaticamente.

    Drives de empresas que são "prospetarias" Intel e agora ADM que esta fornecendo seus drives OpenSources para o Sistemas GNU/Linux.

    ·
  • Então... a placa de vídeo tá um pouco diferente. Normal?
    image.png 249.3K
    ·
  • Papo disse:

    Então... a placa de vídeo tá um pouco diferente. Normal?

    A sua é uma Ryzen 5 3400G a minha é uma Ryzen 5 2400G

    Cade a imagem o print do Gerenciador de Drive?

    ·
Entre ou Registre-se para fazer um comentário.