Alterar resolução para 1366x768

Procurei alguns tópicos e não consegui uma resposta, quando eu usava linux a resolução 1366x768 já vinha por padrão, mas agora não existe essa opção.
Vou colocar o inxi -FxZ aqui:

System:
Host: Tecnologia Kernel: 4.15.0-43-generic x86_64 bits: 64 compiler: gcc
v: 7.3.0 Desktop: MATE 1.20.1 Distro: Linux Mint 19.1 Tessa
base: Ubuntu 18.04 bionic
Machine:
Type: Laptop System: LENOVO product: 2522CS8 v: ThinkPad T410
serial: L1BDHCN
Mobo: LENOVO model: 2522CS8 serial: 1ZHXC0CA5LM BIOS: LENOVO
v: 6IET79WW (1.39 ) date: 07/15/2011
Battery:
ID-1: BAT0 charge: 2.0 Wh condition: 2.3/56.2 Wh (4%) model: SANYO 42T4791
status: Unknown
CPU:
Topology: Dual Core model: Intel Core i5 M 520 bits: 64 type: MT MCP
arch: Nehalem rev: 2 L2 cache: 3072 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19151
Speed: 1204 MHz max: 1199 MHz Core speeds (MHz): 1: 1197 2: 1197 3: 1197
4: 1197
Graphics:
Device-1: Intel Core Processor Integrated Graphics vendor: Lenovo
driver: i915 v: kernel bus ID: 00:02.0
Display: server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa
resolution: 1280x800~60Hz
OpenGL: renderer: Mesa DRI Intel Ironlake Mobile v: 2.1 Mesa 18.0.5
direct render: Yes
Audio:
Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus ID: 00:1b.0
Sound Server: ALSA v: k4.15.0-43-generic
Network:
Device-1: Intel 82577LM Gigabit Network vendor: Lenovo driver: e1000e
v: 3.2.6-k port: 1820 bus ID: 00:19.0
IF: enp0s25 state: down mac: 00:26:2d:fa:62:b2
Device-2: Intel Centrino Advanced-N 6200 driver: iwlwifi v: kernel
port: 1880 bus ID: 03:00.0
IF: wlp3s0 state: up mac: 58:94:6b:01:e8:39
Drives:
Local Storage: total: 465.76 GiB used: 20.93 GiB (4.5%)
ID-1: /dev/sda vendor: Samsung model: HM501II size: 465.76 GiB temp: 37 C
Partition:
ID-1: / size: 91.17 GiB used: 16.20 GiB (17.8%) fs: ext4 dev: /dev/sda5
ID-2: /home size: 358.45 GiB used: 4.73 GiB (1.3%) fs: ext4 dev: /dev/sda6
ID-3: swap-1 size: 7.45 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda1
Sensors:
System Temperatures: cpu: 54.0 C mobo: 0.0 C
Fan Speeds (RPM): cpu: 3831
Info:
Processes: 233 Uptime: 1d 2h 14m Memory: 7.59 GiB used: 3.92 GiB (51.6%)
Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19
inxi: 3.0.27
·

Comentários

  • Opa deu certo, o ruim é que eu coloquei a resolução que estava antes e cortou a tela, não entendi nada aí vou deixar assim mesmo
    ·
  • panico01 disse:

    Opa deu certo, o ruim é que eu coloquei a resolução que estava antes e cortou a tela, não entendi nada aí vou deixar assim mesmo

    Olá meu amigo, primeira mente eu pude observa que você está utilizando o driver server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa, antes de você desistir de resolver o seu problema, que minha opinião é algo muito simples de resolver, procure abrir o gerenciador de driver da sua distro e instala um driver proprietário, e faça os testes, se mesmo depois de instalar um driver proprietário e a resolução continuar fora de escala que é o seu problema em questão, procura salvar a configuração do seu xorg.conf que se encontra na pasta etc/X11, se o mesmo não existir na pasta, execute o comando xorg-configure no terminal, mais antes normalmente se executa esse comando no modo texto desabilitando temporariamente o modo grafico para que o comando possa salvar toda as informações detalhadas e corretas do driver gráfico e do seu monitor, não vou entrar muito em detalhe nessa parte do comando, até porque você tem que ter o habito de e o interesse de aprender a como passar pelos os seus obstáculos, mais resumindo, o seu problema é na sincronização vertical e horizontal que está configurada de maneira errada, basta você saber qual é as configurações do seu monitor e editá-las diretamente no arquivo xorg.conf, vou deixar um exemplo do meu arquivo xorg.conf.

    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings: version 390.77 ([email protected]) Thu Sep 6 07:51:39 UTC 2018

    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "0"
    EndSection

    Section "Files"
    EndSection

    Section "Module"
    Load "dbe"
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx"
    EndSection

    Section "InputDevice"
    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"
    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
    EndSection

    Section "Monitor"
    # HorizSync source: builtin, VertRefresh source: builtin
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "CRT-1"
    HorizSync 24.0 - 80.0
    VertRefresh 50.0 - 75.0
    Option "DPMS"
    EndSection

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce 210"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "Stereo" "0"
    Option "nvidiaXineramaInfoOrder" "CRT-1"
    Option "metamodes" "nvidia-auto-select +0+0"
    Option "SLI" "Off"
    Option "MultiGPU" "Off"
    Option "BaseMosaic" "off"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

    Observações, o driver da placa de vídeo no linux é nvidia-340 mais se você reparar no começo do xorg, diz que as configurações do xorg, pertence ao driver 390, que no meu caso é bem mais atual pertencendo as placas de vídeos mais recentes que a minha, mais como você pode ver, eu pude usa-lo, o seu problema está na sessão (Section "Monitor") da configuração de vídeo do seu driver, no meu veio com a configuração errada nas sincronização HorizSync 24.0 - 80.0 e VertRefresh 50.0 - 75.0, eu só precisei colocar as corretas pertencentes ao meu monitor, e o problema foi resolvido.

    Não tem mistério, se puder deixa as configurações do seu aqui no poste para que eu possa te auxiliar, fica com Deus!
    ·
Entre ou Registre-se para fazer um comentário.