[Resolvido] Erro ao instalar o mint 19: O pacote grub-efi-amd64-signed falhou em instalar-se dentro

mtellesmtelles Marco Telles
Olá,
Após usar Ubuntu, OpenSuse, Fedora e ElementaryOs, migrei para o Mint e vinha usando há um bom tempo em dual boot com o win10 sem problemas. Porém, ao atualizar para a versão 19, Tara, ocorreu ao final, o erro:
O pacote grub-efi-amd64-signed falhou em instalar-se dentro de /target/. Sem o carregador de inicialização GRUB, o sistema instalado não inicializará.
Cheguei a instalar o Mint na opção para instalar sozinho, sem dual boot e apaguei o win10 que não vou usar mais. Deu o mesmo erro.

Acabei instalando o Antergos 18.7 sem problema, depois o MX Linux 17 que finalizou com erro também, mas resolvido com um grub-install. Só não consigo instalar o Mint.

Depois de muito apanhar, só me resta pedir a ajuda de vocês para ter o meu Mint novamente funcionando.

Segue abaixo o resultado do fdisk -l:


Disco /dev/sda: 931,5 GiB, 1000204886016 bytes, 1953525168 setores
Unidades: setor de 1 * 512 = 512 bytes
Tamanho de setor (lógico/físico): 512 bytes / 4096 bytes
Tamanho E/S (mínimo/ótimo): 4096 bytes / 4096 bytes
Tipo de rótulo do disco: gpt
Identificador do disco: BAA98EB4-C8DB-4B20-AAA8-DF8CAA94DBD1

Dispositivo Início Fim Setores Tamanho Tipo
/dev/sda1 2048 411647 409600 200M Sistema EFI
/dev/sda2 411648 935935 524288 256M Linux sistema de arquivos
/dev/sda3 935936 62375935 61440000 29,3G Linux sistema de arquivos
/dev/sda4 62375936 1127403519 1065027584 507,9G Linux home
/dev/sda5 1937424384 1953525134 16100751 7,7G Linux swap
/dev/sda6 1127403520 1188843519 61440000 29,3G Linux raiz (x86)
/dev/sda7 1188843520 1250283519 61440000 29,3G Linux sistema de arquivos
/dev/sda8 1250283520 1311723519 61440000 29,3G Linux sistema de arquivos

Partições lógicas fora da ordem do disco.


Onde:
sda2: /boot
sda3: Antergos /
sda4: /home
sda5: /swap
sda6: MX17 /
sda7: Solus /
sda8: Mint Tara /

Grato por qualquer ajuda! Abs
Post edited by Alquintela on
·

Comentários

  • Olá @mtelles , também tive este mesmo erro ao instalar o Mint 19 no meu ultrabook a solução que encontrei foi simplesmente instalar o sistema sem conexão à internet, segui uma dica de outro site que não recordo agora, e funcionou perfeitamente. Somente depois do sistema instalado e inicializado no Mint 19 é que conectei à internet e baixei as atualizações e instalei os drivers proprietários.

    ·
  • Como o companheiro @Alquintela falou esse problema esta explicado bem aqui nesse link https://forums.linuxmint.com/viewtopic.php?f=90&t=273058&start=40 e como proceder com a instalação do Mint.
    ·
  • mtellesmtelles Marco Telles
    editado 19 de julho
    Ontem resolvi zerar meu hd e reinstalar tudo, já que não uso mais o windows.
    Instalei o MX 17, Mint 19, Antergos e Solus.
    Iniciando pelo Antergos (que tenho usado mais), fiz:
    sudo grub-install /dev/sda
    sudo grub-mkconfig -o /boot/grub/grub.cfg

    Agora tudo funciona ok (exceto o Solus que só entra via Boot Menu F12) e posso usar novamente meu velho e bom Mint :smile:

    Grato pela atenção, abs!

    Post edited by mtelles on
    ·
Entre ou Registre-se para fazer um comentário.