[Resolvido] Problema no Cinnamon - Instalação do Nemo

editado dezembro de 2017 em Sistema
Quando dou um "apt-get install cinnamon", ou tento instalar o Nemo, por exemplo, tenho o seguinte problema:

Os pacotes a seguir têm dependências desencontradas:
cinnamon : Depende: cinnamon-control-center (>= 3.6.0) mas não será instalado
Depende: cinnamon-session (>= 3.6.0) mas não será instalado
Depende: libmuffin0 (>= 3.6.0) mas não será instalado
Depende: gir1.2-meta-muffin-0.0 (>= 3.6.0) mas não será instalado
Depende: nemo (>= 3.6.0) mas não será instalado
Depende: libclutter-1.0-0 (>= 1.23.4) mas não será instalado
Depende: libcogl-pango20 (>= 1.17.4) mas não será instalado
Depende: libcogl-path20 (>= 1.17.4) mas não será instalado
Depende: libcogl20 (>= 1.17.4) mas não será instalado
Depende: libgl1-mesa-glx mas não será instalado ou
libgl1
Depende: gir1.2-gtkclutter-1.0 mas não será instalado
Depende: mesa-utils mas não será instalado
Depende: metacity mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

Se alguém puder me ajudar...
Post edited by Alquintela on
·

Comentários

  • Bem amigo só isso não ajuda muito. Você tem que nos dar mais informações para que possamos tenta ajudar você.

    Por ex: Qual e a versão do Mint que você esta usando? Qual é o ambiente gráfico?
    ·
  • Ao que tudo indica você tem pacotes quebrados. Neste tutorial você tem três maneiras de corrigi-los.

    03 maneiras de corrigir pacotes quebrados

    Espero que resolva.
    ·
  • Alquintela disse:

    Ao que tudo indica você tem pacotes quebrados. Neste tutorial você tem três maneiras de corrigi-los.

    03 maneiras de corrigir pacotes quebrados

    Espero que resolva.

    Boa Noite a todos,

    Alquintela,

    Executei estes 3 procedimentos do DioLinux, mas continuo na mesma.

    Estou usando Mint 18.3 Cinnamon que instalei do zero.

    Não instalei muita coisa (Basicamente: Opera, VirtualBox 51.30).

    Estou tendo problemas com o driver da minha Ralink 3290 (WiFi Caindo) e queria compilar o driver correto e pra isso preciso do build-essentials e aí que aparece o problema.

    Veja:

    sudo apt-get install build-essential linux-headers-generic
    Lendo listas de pacotes... Pronto
    Construindo árvore de dependências
    Lendo informação de estado... Pronto
    Alguns pacotes não puderam ser instalados. Isto pode significar que
    você solicitou uma situação impossível ou, se você está usando a
    distribuição instável, que alguns pacotes requeridos não foram
    criados ainda ou foram retirados da "Incoming".
    A informação a seguir pode ajudar a resolver a situação:

    Os pacotes a seguir têm dependências desencontradas:
    build-essential : Depende: g++ (>= 4:5.2) mas não será instalado
    E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

    Bom, pelo menos não estou sozinho.

    Se alguém puder ajudar agradeço.

    NettoBr
    ·
  • editado dezembro de 2017
    @NettoBr , você ativou o uso de pacotes instáveis no seu Mint? O problema descrito pelo seu sistema se refere a dependências desencontradas e pacotes quebrados devido o uso de distribuição instável, não há referência ao problema com o driver de sua placa de rede wireless (embora este também seja um problema a corrigir, até onde identifiquei não há relação entre eles).
    Se o problema estiver relacionado à ativação do uso da versão instável do Mint, então a solução será desativá-la lá em Fontes de Aplicativos e depois utilizar aqueles comandos que te passei para corrigir os pacotes quebrados.



    Espero que te ajude! Boa sorte!

    P.S.: Qual o ambiente gráfico padrão que você está usando (vi que você está tentando instalar o Cinnamon) e a versão do seu Mint?
    Post edited by Alquintela on
    ·
  • Fala Alquintela, tudo Bem?

    Agradeço sua atenção.

    O primeiro post o "ACDSDUARTE" fala de Instalar o Cinnamon por cima do Mate.

    Eu falei "Estou usando Mint 18.3 Cinnamon que instalei do zero.".

    O problema do driver RT3290 é um... que pra resolver preciso preciso compilar o novo driver.

    Ai vem a necessidade de instalar o build-essentials, mas nessa hora do "apt install" me devolve esta mensagem: "Os pacotes a seguir têm dependências desencontradas:".

    Peguei o bonde andando, mas o erro de instalação é o mesmo.

    Veja meu post acima.

    Não tenho a opção de "Pacotes Instáveis" selecionados.

    Minha politica de atualizações é a "Deixe me revisar atualizações sensíveis".

    Grato pela atenção,

    NettoBr
    ·
  • Problema Resolvido.

    Boa Tarde a Todos.

    Postei minha dúvida tb. no forum internacional do Mint e de lá veio esta dica matadora.

    ______________________________________________________________________________________
    "The following packages have unmet dependencies:
    build-essential : Depends: g++ (>= 4:5.2) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages."

    Classic message, it should be in Elvish across the entrance to the Dungeon, but in English it amounts to...

    "You have a repository attached which is incompatible with your installed OS. I can install build-essential from that repository, but not the dependencies. If I installed that particular build-essential, it would be broken, so I didn't install it."
    ---------------------------------------------------------------------------------------------------------------------------------

    Eu estava usando repositórios da UFPR e UNESP.

    Troquei pelos do Mint e "Voila", problema resolvido.

    Agora entendi porque o DioLinux recomenda não trocar os repositórios.

    Grato a todos,

    NettoBr
    ·
Entre ou Registre-se para fazer um comentário.