[Resolvido] Problemas com o dpkg

Olá!
Estou tentando forçar a instalação do certificado digital, da OAB, seguindo o tutorial que encontrei aqui : https://bkmbr.jusbrasil.com.br/artigos/422963720/como-instalar-o-token-g-d-no-ubuntu-1604-lts-e-derivados

porém, aparece o seguinte erro

tibola-IPX1800E1 tibola # dpkg -force-all -i safesignidentityclient_3.0.77-Ubuntu_i386. Deb
dpkg: erro: opção desconhecida -o

Escreva dpkg --help para ajuda sobre instalar e desinstalar pacotes [*];
Utilize 'apt' ou 'aptitude' para gestão de pacotes amigável;
Escreva dpkg -Dhelp para uma lista de valores de flags de debug do dpkg;
Escreva dpkg --force-help para uma lista de opções para forçar operações;
Escreva dpkg-deb --help para ajuda sobre manipular ficheiros *.deb;

Opções marcadas com [*] produzem muita saída de texto - utilize pipes com 'less' ou 'more' !


Alguém pode me auxiliar
Post edited by Alquintela on
Rotulado:
·
«1

Comentários

  • Já esperimentou usar só o comando

    sudo dpkg -i *.deb

    Ou simplesmente dando dois cliques no arquivo ( .Deb ) e mandando instalar via gráfico?
    ·
  • dá esse erro aqui:

    tibola # sudo dpkg -i *.deb
    dpkg: erro ao processar o arquivo libtiff4_3.9.5-2ubuntu1.9_amd64.deb (--install):
    arquitetura do pacote (amd64) não combina com a do sistema (i386)
    dpkg: erro ao processar o arquivo libwxgtk2.8-0_2.8.12.1-6ubuntu2_amd64.deb (--install):
    arquitetura do pacote (amd64) não combina com a do sistema (i386)
    (Lendo banco de dados ... 263368 ficheiros e directórios actualmente instalados.)
    A preparar para desempacotar safesignidentityclient_3.0.77-Ubuntu_i386.deb ...
    A descompactar safesignidentityclient (3.0.77-14) sobre (3.0.77-14) ...
    dpkg: problemas com dependências impedem a configuração de safesignidentityclient:
    safesignidentityclient depende de libwxbase2.8-0 (>= 2.8.12.1); porém:
    Pacote libwxbase2.8-0 não está instalado.
    safesignidentityclient depende de libwxgtk2.8-0 (>= 2.8.12.1); porém:

    dpkg: erro ao processar o pacote safesignidentityclient (--install):
    problemas de dependência - deixando desconfigurado
    A processar 'triggers' para hicolor-icon-theme (0.15-0ubuntu1) ...
    A processar 'triggers' para man-db (2.7.5-1) ...
    A processar 'triggers' para desktop-file-utils (0.22+linuxmint1) ...
    A processar 'triggers' para mime-support (3.59ubuntu1) ...
    Erros foram encontrados durante o processamento de:
    libtiff4_3.9.5-2ubuntu1.9_amd64.deb
    libwxgtk2.8-0_2.8.12.1-6ubuntu2_amd64.deb
    safesignidentityclient
    ·
  • editado 17 de outubro
    Eis a razão do erro meu caro, dpkg: erro ao processar o arquivo libtiff4_3.9.5-2ubuntu1.9_amd64.deb (--install):
    arquitetura do pacote (amd64) não combina com a do sistema (i386).

    Você está tentando instalar um pacote de 64bit num sistema de 32bit. Não vai conseguir mesmo forçando. Procure ver no lugar onde você fez o download se existe uma versão do pacote para arquitetura 32bit (i386). Caso não exista, então o jeito é instalar no seu computador a versão 64bit do Mint, se o hardware dele suportar esta arquitetura.

    PS.: sempre que tiver no título do pacote a informação amd64 quer dizer que ele é próprio para sistemas de 64bit, se tiver i386, quer dizer que foi feito para sistemas de 32bit.
    Post edited by Alquintela on
    ·
  • Obrigado pelo auxílio... realmente, tinha baixado o arquivo errado.
    Consertei isso, porém agora o erro é esse:

    tibola # sudo dpkg -i *.deb
    (Lendo banco de dados ... 265894 ficheiros e directórios actualmente instalados.)
    A preparar para desempacotar safesignidentityclient_3.0.77-Ubuntu_i386.deb ...
    A descompactar safesignidentityclient (3.0.77-14) sobre (3.0.77-14) ...
    dpkg: problemas com dependências impedem a configuração de safesignidentityclient:
    safesignidentityclient depende de libwxbase2.8-0 (>= 2.8.12.1); porém:
    Pacote libwxbase2.8-0 não está instalado.
    safesignidentityclient depende de libwxgtk2.8-0 (>= 2.8.12.1); porém:
    Pacote libwxgtk2.8-0 não está instalado.

    dpkg: erro ao processar o pacote safesignidentityclient (--install):
    problemas de dependência - deixando desconfigurado
    A processar 'triggers' para hicolor-icon-theme (0.15-0ubuntu1) ...
    A processar 'triggers' para man-db (2.7.5-1) ...
    A processar 'triggers' para desktop-file-utils (0.22+linuxmint1) ...
    A processar 'triggers' para mime-support (3.59ubuntu1) ...
    Erros foram encontrados durante o processamento de:
    safesignidentityclient
    ·
  • editado 17 de outubro
    O problema agora é com a dependência desses dois pacotes que não estão instalados: libwxbase2.8-0 e libwxgtk2.8-0.

    Peguei aquele tutorial que você colocou aqui e achei a solução para este problema com dependências. Basta seguir o que diz lá:

    "Para eliminar os erros de dependência que podem atrapalhar o sistema de atualização automática do sistema é necessário alterar um arquivo. Ainda no terminal como root digite:

    gedit /var/lib/dpkg/status

    (Se você você estiver utilizando o kubuntu deverá trocar o gedit para kedit, se estiver utilizando o lubuntu deve trocar o gedit por leafpad e assim por diante) Veja qual o editor de texto você usa ou tem instalado em seu sistema.

    Com o arquivo aberto, aperte a combinação de teclas Ctrl+F e digite "safesign" (sem as aspas) no campo de buscas.

    Na seção "Depends" logo abaixo da linha encontrada estão listadas as dependências do pacote da SafeSign. Os pacotes que causam os erros são o libwxbase2.8-0 (>= 2.8.12.1) e o libwxgtk2.8-0 (>= 2.8.12.1). Apague essas strings do arquivo, salve e feche o programa.

    Agora você já pode conectar o token do certificado digital. Se tudo der certo o LED no token deve ficar acesso e você pode fechar a janela do terminal."


    Espero que dessa vez tudo ocorra com perfeição!

    P.S.: Fique atento ao editor de texto, pois o Mint não usa mais o gedit como padrão, acredito que você, assim como eu, esteja usando o xed, neste aquele comando para editar o arquivo deve ser assim: xed /var/lib/dpkg/status
    Post edited by Alquintela on
    ·
  • Obrigado, novamente!

    Segui todos os passos, porém, mesmo assim, infelizmente, o token não funciona.

    Não sei mais o que fazer...

    :(
    ·
  • tibola10 disse:

    Obrigado, novamente!

    Segui todos os passos, porém, mesmo assim, infelizmente, o token não funciona.

    Não sei mais o que fazer...

    :(

    Qual seria a versão do seu Mint?
    ·
  • Da uma verificada nesse outro link.

    Tem umas informações que pode te ajudar.
    ·
  • Consegui.. Obrigado!
    ·
Entre ou Registre-se para fazer um comentário.