Não consigo instalar a IDLE Python

Baixei a versão mais recente do ambiente de desenvolvimento, 3.6.1 depois descompactar e tentar instalar aparece esses erros;

./configure
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for python3.6... no
checking for python3... python3
checking for --enable-universalsdk... no
checking for --with-universal-archs... no
checking MACHDEP... linux
checking for --without-gcc... no
checking for --with-icc... no
checking for gcc... gcc
checking whether the C compiler works... no
configure: error: in `/home/mario/Downloads/Python-3.6.1':
configure: error: C compiler cannot create executables
See `config.log' for more details

make
make: *** Nenhum alvo indicado e nenhum arquivo make encontrado. Pare.

make test
make: *** No rule to make target 'test'. Pare.

sudo make install
[sudo] senha para mario:
make: *** No rule to make target 'install'. Pare.

Como faço para instalar ele?
·

Comentários

  • Já tentou utilizar o PyCharm, eu usava no Xubuntu 16.04, funciona muito bem, segue link, https://www.jetbrains.com/pycharm/download/#section=linux
    ·
  • Instalei ontem, só usei esse comando:

    sudo apt-get install idle3

    Boa sorte.
    ·
  • O PyCharm é muito bom, e tem a versão da comunidade.
    ·
  • nnr disse:

    O PyCharm é muito bom, e tem a versão da comunidade.

    Fiz a instalação da versão antiga e instalei a versão mais recente, so que ta dando conflito como faço para remover todas as versões e instalar novamente a mais atual?

    ·
  • Olá @Mario, primeiro você deve desinstalar normalmente todas as versões que estão presentes no seu computador. Você pode remover pelo terminal, pelo Gerenciador de Aplicativos ou pelo Gerenciador de Pacotes Synaptic.

    Pelo terminal: sudo apt-get remove nome-do-programa ou sudo apt-get purge nome-do-programa, em seguida use o comando sudo apt-get autoremove que serve para desinstalar os pacotes que não são mais necessários no sistema e que podem gerar conflito.

    ·
  • Cara, instala o pacote build-essential e tenta de novo.
    ·
Entre ou Registre-se para fazer um comentário.