Mint 18 não iniciar com comando no rc.local

Olá pessoal.

Estou com problema para iniciar serviio junto com o Mint. Uso o Mint 18.1 32 e consigo rodar o Serviio 1.8, contudo quanto coloco o Serviio e o X11vnc para iniciar pelo systemctl, o X11vnc para de funcionar. Para resolver a questão coloquei o Serviio para iniciar pelo /etc/rc.local. Ai é que está o problema, quando coloco o comando /opt/serviio-1.8/bin/serviio.sh no rc.local o sistema não inicia. Fica na tela de carregamento e não sobe. Se eu retiro o comando o sistema inicia normalmente. Fiz o teste com o Mint 17.3 e não apresenta esse erro.

Por favor, vcs poderiam me ajudar a resolver esse problema. Caso precisem de mais informações sobre o erro é só avisar.
·
«1

Comentários

  • editado junho de 2017
    Você não identificou que ambiente de interface está usando, mas no meu Cinnamon posso iniciar apps com o sistema facilmente através da ferramenta Aplicativos de Inicialização.
    Post edited by dougpess on
    ·
  • quando eu coloco para iniciar pelo rc.local eu deixo o script dentro do /etc/init.d, como no seu caso não é propriamente um script vc poderia tentar a solução mais simples, colocar o comando do programa no aplicativos de sessão.

    vc pode também colocar o comando (nao caminho) dos dois programas num arquivo texto, dá permissao de execuçao e coloca o caminho do arquivo no aplicativos de sessao.
    ·
  • editado junho de 2017
    Troca o proprietário da pasta /opt/serviio-1.8 e todo seu conteúdo para root:
    sudo chown -R root /opt/serviio-1.8
    Post edited by dougpess on
    ·
  • editado junho de 2017
    dougpess disse:

    Você não identificou que ambiente de interface está usando, mas no meu Cinnamon posso iniciar apps com o sistema facilmente através da ferramenta Aplicativos de Inicialização.

    Muito obrigado por responder dougpess. Tentei o sugerido. O Serviio inicia somente quando faço login, como é um servidor doméstico de multimídia nem sempre estará logado. Além disso, quando fui adicionar uma pasta para compartilhar ele apresenta uma mensagem de erro. Em outros testes quando inicio o serviio pelo rc.local esse erro não ocorre.

    Também testei a sua sugestão: root -R /opt/serviio-1.8. Infelizmente não funcionou, também.

    Esqueci de mencionar que estou XFCE 32 bits.
    Post edited by decorpse on
    ·
  • Corrigi o comando agora pouco pois tinha faltado "sudo". Tente outra vez.
    ·
  • luiz99 disse:

    quando eu coloco para iniciar pelo rc.local eu deixo o script dentro do /etc/init.d, como no seu caso não é propriamente um script vc poderia tentar a solução mais simples, colocar o comando do programa no aplicativos de sessão.

    vc pode também colocar o comando (nao caminho) dos dois programas num arquivo texto, dá permissao de execuçao e coloca o caminho do arquivo no aplicativos de sessao.

    Obrigado por responder.Tentei o sugerido. O Serviio inicia somente quando faço login, como é um servidor doméstico de multimídia nem sempre estará logado. Além disso, quando fui adicionar uma pasta para compartilhar ela apresenta uma mensagem de erro. Em outros testes quando inicio o serviio pelo rc.local esse erro não ocorre.

    Parece um bug da versão. Pois quando tento no Mint 17 o problema não acontece. Estou tentando corrigir na 18.1, pois é mais atual e gosto mais dela.
    ·
  • dougpess disse:

    Corrigi o comando agora pouco pois tinha faltado "sudo". Tente outra vez.

    Eu já havia feito como sudo. Também dei permissão 777 na pasta do serviio chmod -R 777 serviio-1.8:

    drwxr-xr-x 3 root root 4096 Jun 6 22:00 ./
    drwxr-xr-x 23 root root 4096 Jun 6 20:57 ../
    drwxrwxrwx 9 root root 4096 Jun 6 22:01 serviio-1.8/
    ·
  • editado junho de 2017
    Compartilhe conosco o conteúdo do seu rc.local.

    Sugiro o uso de https://pastebin.com/ nesta tarefa
    Post edited by dougpess on
    ·
  • editado junho de 2017
    dougpess disse:

    Compartilhe conosco o conteúdo do seu rc.local.

    Sugiro o uso de https://pastebin.com/ nesta tarefa

    Segue:
    https://pastebin.com/raw/apvsNKD9
    Post edited by decorpse on
    ·
  • editado junho de 2017
    Não sei mais como ajudar, mas encontrei esse guia de instalação do Serviio 1.8 que talvez seja útil pra você.
    http://wiki.serviio.org/doku.php?id=howto:linux:install:ubuntu15-04

    OBS: Um app da mesma categoria que adoro é o Universal Media Server (UMS).

    Boa sorte!
    Post edited by dougpess on
    ·
Entre ou Registre-se para fazer um comentário.