SmartCard não funcionou no Linux

L_HenriqueL_Henrique Luiz Henrique
editado novembro de 2015 em Hardwares e Periféricos
Amigos Boa tarde!
Sou novato na utilização do Linux Mint e estou com dificuldade em fazer funcionar o leitor de cartões Smart Card no meu linux.
Até o momento a minha experiência com o Mint foi só alegria, a instalação foi 100% perfeita e sem interferência e sem erro algum.
Versão: Linux Mint 17.2 "Rafaela" - Cinnamon (64-bit).
Laptop: Acer Aspire M5 - 481 - I5 com 6 Gb.
SmatCard = SmartNonus.
Drive do Fabricante = EZUSB_Linux_x86_64_v1.5.3.
Compatibilidade (conforme site do fabricante):
- PC/SC;
- Suporta Protocolo T=0 e T=1;
- ISO 7816 1,2,3 e 4;
- ISO 7816
- Classe A e Classe AB;
- EMV 2000 4.1;
- StarCOS SPK 2.3;
- ICP Brasil;

Link do Fabricante: http://www.nonus.com.br/Prod_Smartnonus.php?gclid=CJisqpTBmskCFRQEkQodqtwFiA#.Vky2803ltaR[b]

Comando = inxi -FxZ:[/b]
System: Host: anchite-Aspire-M5-481T Kernel: 3.16.0-38-generic x86_64 (64 bit, gcc: 4.8.2)
Desktop: Cinnamon 2.6.13 Distro: Linux Mint 17.2 Rafaela
Machine: System: Acer product: Aspire M5-481T version: V2.16
Mobo: Acer model: MA41_CX version: Type2 - A01 Board Version Bios: Insyde version: V2.16 date: 01/17/2013
CPU: Dual core Intel Core i5-3337U CPU (-HT-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 7183.62
Clock Speeds: 1: 882.00 MHz 2: 929.320 MHz 3: 2307.375 MHz 4: 1355.484 MHz
Graphics: Card: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
X.Org: 1.15.1 drivers: intel (unloaded: fbdev,vesa) Resolution: [email protected]
GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 10.1.3 Direct Rendering: Yes
Audio: Card: Intel 7 Series/C210 Series Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture ver: k3.16.0-38-generic
Network: Card-1: Qualcomm Atheros AR9462 Wireless Network
Adapter driver: ath9k bus-ID: 09:00.0
IF: wlan0 state: up mac: 1c:3e:84:0f:65:6d
Card-2: Broadcom NetLink BCM57780 Gigabit Ethernet PCIe driver: tg3 ver: 3.137 bus-ID: 04:00.0
IF: eth0 state: down mac: 08:9e:01:87:3e:1b
Drives: HDD Total Size: 520.1GB (1.1% used) 1: id: /dev/sda model: ST500LT012 size: 500.1GB
2: id: /dev/sdb model: SATA_SSD size: 20.0GB
Partition: ID: / size: 453G used: 5.3G (2%) fs: ext4 ID: swap-1 size: 6.24GB used: 0.00GB (0%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: System Temperatures: cpu: 46.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 178 Uptime: 11 min Memory: 396.4/5782.2MB Runlevel: 2 Gcc sys: 4.8.4
Client: Shell (bash 4.3.11) inxi: 1.9.17

[b]Comando lspci:[/b]
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
00:1c.7 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 8 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM77 Express Chipset LPC Controller (rev 04)
00:1f.2 IDE interface: Intel Corporation 7 Series Chipset Family 4-port SATA Controller [IDE mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
00:1f.5 IDE interface: Intel Corporation 7 Series Chipset Family 2-port SATA Controller [IDE mode] (rev 04)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
04:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)
09:00.0 Network controller: Qualcomm Atheros AR9462 Wireless Network Adapter (rev 01)


[b]Comando uname -r:[/b]
3.16.0-38-generic

[b]Comando pscs_scan:[/b]
PC/SC device scanner
V 1.4.22 (c) 2001-2011, Ludovic Rousseau
Compiled with PC/SC lite version: 1.8.10
SCardEstablishContext: Service not available.

Ps. Funciona normal no Windows 10.

Obrigado pela atenção.
·

Comentários

  • editado novembro de 2015
    Olá Luiz, algumas dúvidas minhas: você instalou o driver conforme recomendação do site do fabricante? Você entrou em contato com o suporte técnico da empresa?

    [url=http://www.nonus.com.br/Prod_Smartnonus.php?gclid=CJisqpTBmskCFRQEkQodqtwFiA#.Vk9gB3rQQjO]Link de download do driver e do manual de instalação[/url]

    Infelizmente não posso te ajudar além disso, pois não tenho este dispositivo para tentar fazer rodar. Talvez algum outro colega já tenha trabalhado com este dispositivo.

    Abraço companheiro e qualquer sucesso favor postar aqui como foi resolvido.
    ·
Entre ou Registre-se para fazer um comentário.