Problemas com compilação de modo geral

GuhLelouchGuhLelouch Gustavo
editado fevereiro de 2014 em Programação e Scripts
Olá, pessoal.

Estou tentando instalar em meu computador dois programas chamados GROMACS e GROMOS (usados para simulação de dinâmica molecular). No entanto, para instalá-los, vários pré-requisitos são necessários (principalmente o GROMOS). Preciso instalar pacotes que dependem de outros pacotes, que dependem de outros pacotes, os quais, por sua vez, dependem de outros pacotes. Está difícil, pois toda vez que tento compilar um desses pacotes, acontece algum erro diferente, e aí preciso instalar outros pacotes para garantir que não foi essa a origem do erro. Estou usando o Linux MInt 16 XCFE 64bits, recém instalado.

Gostaria de saber, portanto, se não existe uma maneira mais prática de instalar esses pacotes envolvidos na compilação.

O erro mais recente que eu tive foi durante a compilação do coreutils-8.22. Não achei em nenhum lugar uma solução para o mesmo. O erro é o seguinte:

[code]/usr/lib/gcc/x86_64-linux-gnu/4.8/crtbeginT.o: error adding symbols: Bad value[/code]

Sou iniciante no Linux, e qualquer dica que me mandarem para solucionar esses problemas será bem vinda.
·

Comentários

  • editado fevereiro de 2014
    Sou [d]analfabeto[/d] leigo em dinâmica molecular, mas pelo que entendi o Gromacs é uma versão opensource do Gromos e [url=http://www.biostars.org/p/53145/][b]neste fórum em inglês[/b][/url] há um pedido de ajuda semelhante ao teu.

    O ajudante informa que o Gromacs existe no repositório oficial do Ubuntu 12.04 e o aconselha como alternativa ao Gromos.

    Verifiquei no LM16 e existe lá o programa Gromacs. Para instalá-lo basta ir no Gerenciador de Aplicativos, procurar pelo programa e instalá-lo. Ou se preferir, abra o terminal e digite: [b]sudo apt-get install gromacs[/b]

    Antes aconselho remover os pacotes que você instalou, para isso, faça o seguinte:
    Como root digite no terminal:

    1º) [b]apt-get update[/b]
    2°) [b]dpkg --configure -a[/b]
    3°) [b]apt-get -f install[/b]

    Abraço!

    ·
  • editado fevereiro de 2014
    [quote]
    Gustavo wrote:
    Olá, pessoal.

    Estou tentando instalar em meu computador dois programas chamados GROMACS e GROMOS (usados para simulação de dinâmica molecular). No entanto, para instalá-los, vários pré-requisitos são necessários (principalmente o GROMOS). Preciso instalar pacotes que dependem de outros pacotes, que dependem de outros pacotes, os quais, por sua vez, dependem de outros pacotes. Está difícil, pois toda vez que tento compilar um desses pacotes, acontece algum erro diferente, e aí preciso instalar outros pacotes para garantir que não foi essa a origem do erro. Estou usando o Linux MInt 16 XCFE 64bits, recém instalado.

    Gostaria de saber, portanto, se não existe uma maneira mais prática de instalar esses pacotes envolvidos na compilação.

    O erro mais recente que eu tive foi durante a compilação do coreutils-8.22. Não achei em nenhum lugar uma solução para o mesmo. O erro é o seguinte:

    [code]/usr/lib/gcc/x86_64-linux-gnu/4.8/crtbeginT.o: error adding symbols: Bad value[/code]

    Sou iniciante no Linux, e qualquer dica que me mandarem para solucionar esses problemas será bem vinda.[/quote]

    Creio que você deve instalar primeiro os pacotes necessários para compilação, segue abaixo um link com dicas do Hamacker:
    [url=http://hamacker.wordpress.com/ubuntu-perfeito/ubuntu-perfeito-faca-voce-mesmo/possuir-o-basico-para-compilar-programas-e-modulos/]Básico para compilação Hamacker[/url]

    Boa sorte!

    Edson
    "Somente quando um mosquito pousa em seu testículo é que você se dá conta de que nem tudo se resolve no tapa."
    ·
Entre ou Registre-se para fazer um comentário.